handogin1999
10.05.2023 17:53

Напишите программу, которая вычисляет значение следующего выражения:
6a2+15ab-13b2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
adrien3000
01.02.2021 16:09

N = int(input('Введите N (строки): '))

M = int(input('Введите M (столбцы): '))

array_1 = []

array_2 = []

array_3 = []

el = 0

for i in range(N):

   a = []

   if M % 2 == 0 and i > 0:

       if el == 0:

           el = 1

       else:

           el = 0

   for _ in range(M):

       a.append(el)

       if el == 0:

           el = 1

       else:

           el = 0

   array_1.append(a)

print('Задание 1.')

for row in array_1:

   for el in row:

       print(el, end = ' ')

   print()

for i in range(N):

   a = []

   for j in range(N):

       if j > i:

           a.append(0)

       else:

           a.append(1)

   array_2.append(a)

print()

print('Задание 2.')

for row in array_2:

   for el in row:

       print(el, end = ' ')

   print()

           

for i in range(N):

   a = []

   for j in range(N):

       if j < N - i - 1:

           a.append(0)

       else:

           a.append(1)

   array_3.append(a)

print()

print('Задание 3.')

for row in array_3:

   for el in row:

       print(el, end = ' ')

   print()

0,0(0 оценок)
Ответ:
Намиг123
29.09.2020 21:13

Если П и Ж аборигены, то она должны всегда говорить правду.Значит Ж(абориген)говорит правду, что он абориген и П передаёт правду. Он абориген.

Если П иЖ пришельцы, то они должны врать.Значит Ж говорит (неправду) я абориген, и П передаёт он пришелец. ---несоответствует контексту.

Если П-пришелец,а Ж-абориген, то П должен врать, а Ж говорить правду. Значит Жсказал правду " я абориген", а проводник передал он пришелец. --- несоответсвует контексту.

Если П- абориген, а Ж пришелец, то П всегда говорит правду, а Ж неправду. Значит  сказал" неправду "я абориген" а П передал он абориген.

В обоих случаях проводник абориген.

 

П- проводник

Ж - житель

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота