karinakarina9
15.01.2023 00:05

Где и как написать программу кроме Паскаля нечего не понимаю​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
clykovsa
25.03.2023 15:38
Var n, a, pos, neg, null, i: integer;
 begin
  pos := 0;
  neg := 0;
  null := 0;
  writeln('Введите N:');
  readln(n);
  writeln('Введите N целых чисел:');
  for i := 1 to n do
   begin
    read(a);
    if(a < 0) then neg := neg + 1;
    if(a > 0) then pos := pos + 1;
    if(a = 0) then null := null + 1;
  end;
  writeln('Положительных чисел: ', pos);
  writeln('Отрицательных чисел: ', neg);
  writeln('Нулей: ', null);
end.
Тестовые решения:
1)ввод
8
1 2 0 3 0 -5 -4 2
вывод
Положительных чисел: 4
Отрицательных чисел: 2
Нулей: 2
2)ввод
6
0 0 3 -5 0 22
вывод
Положительных чисел: 2
Отрицательных чисел: 1
Нулей: 3
0,0(0 оценок)
Ответ:
школоллло
25.03.2023 15:38

var

  number, N, npol, notr, n0, i: integer;  {npol - количество положительных чисел, notr - количество отрицательных, n0 - количество нулей}

 

begin

  writeln('Введите N');

  readln(N);

  for i:= 1 to N do

  begin

    writeln('Введите целое число');

    readln(number);

    if number < 0 then notr:= notr + 1;

    if number > 0 then npol:= npol + 1;

    if number = 0 then n0:= n0 + 1;

  end;

  writeln('Было введено ', notr, ' отрицательных чисел, ', npol, ' положительных чисел, ', n0, ' нулей');

end.

А для тестов ты просто вводишь числа и проверяешь, правильно ли нашлось количество.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота