haylayjonesty
26.12.2021 15:12

Задача на цикл WHILE:
Написать программу, которая ищет n!. n! = 1 * 2 * 3 * … * (n-2) * (n-1) * n
Задача на цикл REPEAT:
Написать программу, которая определяет является ли число, введенное с
клавиатуры Подсказка: найдите алгоритм “решето Эратосфена”
Задача на цикл FOR:
Написать программу, которая находит число P = (1-1/2)(1-1/3)*…*(1-1/n).
N вводится с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
сснсогаоаг
22.04.2023 10:06
1.
var x1,x2,x3,y1,y2,y3,a,b,c,p,s:real;
begin
readln(x1,y1);
readln(x2,y2);
readln(x3,y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
c:=sqrt(sqr(x1-x3)+sqr(y1-y3));
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S=',s,';');
end.

2.
var n,i,j,Sn,si:int64;
begin
readln(n);
Sn:=0;

for i:=1 to n do
begin
Si:=1;
for j:=i to i*2 do Si:=Si*j;
Sn:=Sn+Si;
end;

writeln('Sn=',Sn,';');

end.

Для составления блок-схемы могу объяснить довольно простой алгоритм:
Ты проходишься одной переменной от 1 до n, и в каждом проходе ты
Вычисляешь произведение чисел от значения той переменной до ее удвоенного значения другим циклом
И в конце прохода главного цикла ты прибавляешь к результирующей переменной (которая в начале программы была обнулена) то произведение, которое ты только что вычислил.

P.S. Возможно на словах это звучит довольно-таки непонятно, но для этого есть код, который поясняет весь алгоритм
0,0(0 оценок)
Ответ:
dashkin21
01.10.2021 09:58

Контекстное обучение [лат. contextus — тесная связь, сцепление, сплетение] — обучение, в котором динамически моделируется предметное и социальное содержание профессионального труда, тем самым обеспечиваются условия трансформации учебной деятельности студента в профессиональную деятельность специалиста (А.А. Вербицкий). Основное противоречие профессионального обучения состоит в том, что овладение деятельностью специалиста должно быть обеспечено в рамках и средствами качественно иной — учебной деятельности. Это противоречие преодолевается в К. о., представляющем собой реализацию динамической модели движения деятельности студентов: от собственно учебной деятельности (в форме лекции, например) через квазипрофессиональную (игровые формы) и учебно-профессиональную (научно-исследовательская работа студентов, производственная практика и др.) к собственно профессиональной деятельности с соответственно, семиотической, имитационной и социальной обучающих моделей. В формах собственно учебной деятельности реализуются главным образом процедуры передачи и усвоения студентами знаковой информации (семиотическая обучающая модель)- в квазипрофессиональной деятельности в аудиторных условиях и на языке наук воссоздается предметное и социальное содержание усваиваемой деятельности (имитационная обучающая модель). В учебно-профессиональной деятельности студенты, оставаясь в позиции обучающихся, выполняют профессиональные действия и поступки- формы организации такой деятельности практически воспроизводят формы реальной профессиональной деятельности (социальная обучающая модель).

Основной единицей задания содержания образования в К. о. выступает проблемная ситуация во всей своей предметной и социальной неоднозначности и противоречивости. Система таких ситуаций позволяет развертывать содержание образования в динамике путем задания сюжетной канвы моделируемой профессиональной деятельности, создает возможности интеграции знаний всех других научных дисциплин, необходимых для разрешения этих ситуаций. Основной единицей деятельности студента является поступок, посредством которого будущий специалист не только выполняет предметные действия в соответствии с требованиями и нормами профессии, но и получает нравственный опыт, поскольку действует в соответствии с нормами отношений, принятых в данном обществе и в данном профессиональном сообществе. Тем самым решается проблема единства обучения и воспитания в рамках целостного образовательного процесса.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота