zajka23oz3xl9
19.07.2020 08:33

НУЖНО НАПИСАТЬ ПРОГРАММЫ В Python.

Задание 1. Гипотеза Гольдбаха утверждает, что каждое нечетное число является суммой трёх чисел. Напишите программу, которая получает положительные нечетные числа от пользователя, и находит для них все тройки положительных чисел, которые в сумме дают само число. Проверку правильности гипотезы Гольдбаха и обеспечение правильности ввода данных пользователем оформите в виде вс функций. Программа должна работать до тех пор, пока на во Продолжить? (да/нет):» последует ответ «нет».
Задание 2. Наибольший общий делитель (НОД) двух целых чисел можно вычислить с алгоритма Евклида. Начиная со значений m и n мы последовательно применяем формулу n, m = m, n%m, пока m не станет равным 0. В этот момент n = НОД. Напишите программу, которая вычисляет НОД двух чисел с описанного алгоритма. Вычисление НОД и обеспечение правильности ввода данных пользователем оформите в виде вс функций. Программа должна работать до тех пор, пока на во Продолжить? (да/нет):» последует ответ «нет».
Задача 3. Напишите вс функцию, которая рисует с черепашки круглые часы. Воспользуйтесь вс функцией в основной программе, которая в цикле ввести координаты точки А и рисует заполненный треугольник (расширяющийся вниз) из часов, самые верхние часы содержат точку А, по высоте 7-15 (случайное число) штук часов. Еще одна вс функция должна обеспечить правильность ввода данных в программу. Основная программа должна работать до тех пор, пока пользователь на во Продолжить? (да/нет):» ответит «нет».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arishatopic
28.04.2023 04:41
Для того что бы округлить нужно использовать "=ОКРУГЛ" данная команда округляет число до указанного количества десятичных разрядов, цифр после запятой. (что бы округлить сумму нужно записывать количество десятичных разрядов в конце выражения). Пример:«=ОКРУГЛ(выражение);число)»

Дано:

Математическое выражение:
«(89+75)−2(72:(3+7))»

Найти:
Значение выражения и округлить его в MS Ecxel.

Формула (Её нужно ввести в окошко Excel и нажать "Enter"):
«=ОКРУГЛ((89+75)-2*(72/(3+7));2)»

ответ:
149,6

(До сотых программа округлить не может, ибо число имеет только десятые в ответе)

Далее скриншот, и файл Excel в котором формула и сам ответ.


Вычисли значение выражения в ms excel: (89+75)−2(72: (3+ (ответ округли до сотых)
0,0(0 оценок)
Ответ:
Vita1968
24.04.2023 19:01
Const n=8;
var x : array[1..n] of real;
   i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=20*random-10;
  write(x[i]:6:2,' ');     
 end;
 writeln;
min:=x[1];
for i:=2 to n do
 if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
 if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.

Пример:
Исходный массив:
 -7.84  -9.97   7.00  -8.26  -7.71  -3.88   7.59  -2.32 
min= -9.97
Измененный массив:
 -9.97  -9.97   7.00  -9.97  -9.97  -9.97   7.59  -9.97 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота