crosser001
19.06.2022 13:55

РЕБЯТА, УМОЛЯЮ НУЖНО ОЧЕНЬ ЗАРАНЕЕ ОГРОМНОЕ Ниже приведена программа:

var s,k: integer;
begin
readln(s);
readln(t);
if (s < 1) and (t < 2)
then
writeln ('YES')
else
writeln ('NO')
end.
Было выведено 9 запусков программы, при которых в качестве значений переменных вводились следующие пары чисел (s, t):

(3, 5); (4, 3); (4, −5); (0, 7); (0, −2); (−2, 1); (−2, 5); (−2, −4); (1, 2).

Сколько было запусков, при которых программа напечатала «NO»? В качестве решения выпишите все пары запусков и напротив каждого укажите вывод: YES или NO. В ответе укажите количество.

2. Составьте программу, выводящую значение вещественной переменной x, равной значению выражения 2(a+b)/a^2,где a и b – целочисленные переменные, их значения вводятся с клавиатуры.

3. Целое положительное число вводится с клавиатуры. Нужно проверить является ли оно четным.

4. Напишите программу, которая вычисляет сумму n-первых целых положительных чисел S = 1 + 2 + 3 + … + n. Количество суммируемых чисел n должно вводиться пользователем во время работы программы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vampire1234
07.07.2022 00:38
Прикладываю исходник и скрин в приложении к ответу.

Несколько замечаний:

1. Большое количество комментариев внесено в код исключительно в учебных целях. В реальную программу переносить не рекомендуется - признак нехорошего тона.

2. У вас допущены синтаксические ошибки в двух последних циклах, а точнее - в операторах If, в которых стоит три условия (объединённых and), но нет ключевого слова "then" и последующих инструкций. Исправил.

3. Так же, автор вашей программы построил на мой взгляд нелогичную структуру алгоритма. Переменные min, min2 и min3, как я догадался, должны хранить три минимальных значения массива.
А вот что происходит в вашей конструкции: первый цикл безошибочно находит наименьший элемент и записывает его в min, а последующие два цикла записывают в min2 и min3 первые попавшиеся(начиная с первого) элементы, если они больше min. Таким образом, нет никакой закономерности в том, что попадёт в эти переменные и сложно представить, для какой задачи потребовались бы такие случайности.

Одним из вариантов решения предлагаю изначально записывать в эти три переменные не значение первого элемента массива, а какое-то большое число, которое в массиве нам не встретится (например 100). Тогда цикл будет искать значения меньше 100 и перезаписывать им соответствующую переменную, пока не найдёт самое маленькое значение. В таком случае не очень стабильная переменная j нам так же не нужна, я её вычеркнул.

Вам отсылаю уже с учётом поправок, однако если вам требовалась именно первоначальная версия несмотря на её минусы, просто поправьте синтаксис в последних циклах (41 и 34 строчка на скрине) и пользуйтесь ей.

Объясните как работает эта программа по-шагово program lklkjo; uses crt; const n=10; var a: array[1.
0,0(0 оценок)
Ответ:
лисичка132
13.05.2020 23:50
Наука Науки бывают разные. Есть батаника астрономия и т. д. Каждая наука изучает что-то. Например батаника изучает растения. Я думаю что очень интересно изучать какую нибудь науку! Образование Мне кажется что образование нужно каждому. Каждый человек должен быть образованным. Для этого нужно ходить в школу. Закончить 9-11 классы и пойти на работу. Культура Тебе наверно известно слово культура. Мне кажется что все люди должны быть культурными. Но к сожалению не все люди могут быть культурными. С культурным человеком приятно общаться.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота