veronichkasape
22.04.2020 16:35

11. Чему равна сумма элементов а[1] и а[4] массива, сформированного следующим образом?
for i:=1 to 5 do a[i] := i * i;
a) 5
б) 15
в) 55
г) 40
12. Массив описан следующим образом:
const b: array [1..5] of integer = (1, 2, 3, 4, 7);
Значение выражения b[5] * b[4] — b[2] — b[3] * b[1] равно:
a) 22 б) 15 в) 11 г) 23

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vladyulin
29.04.2021 23:44
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Ответ:
tarasIT
15.10.2022 21:16
Rem BASIC-256
cls
errors = 0
print "Введите текст > ";

rem Пользователь вводит текст
input a$

rem Перебираем все буквы с начала и до предпоследней
for i=1 to length(a$)-1

rem Если встречаем букву Ч или Щ
if mid(a$, i, 1) = "ч" or mid(a$, i, 1) = "щ" then

rem Тогда проверяем следующую за ней букву.
rem Если это буква я, тогда подсчитываем очередную ошибку
if mid(a$, i + 1, 1) = "я" then errors = errors + 1
end if

rem Переходим к следующей букве
next i

rem Вывод результата
print "Количество ошибок в тексте ";
print errors

rem Конец программы
end
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота