shittt6655
15.05.2020 04:53

Решить в программе паскаль
Составить программу, которая находит и выводит
сумму натуральных чисел от 1 до 6,
кратных 5 и оканчивающихся на 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
veroonikanovit
12.06.2021 02:07

а)

монитор, клавиатура, мышка. Хотя можно изворотится и без мышки сделать, но это сложно.

Adobe photoshop,  UltraISO

б)

подключить оборудование, открыть photoshop, смотри изображение, открываем сайт (https://online-audio-converter.com/ru/) и конвертируем видео в mp3, запускаем программу UltraISO

, В окно программы перетягиваем файлы которые нужно записать, Нажимаем на кнопку записи  (иконка горящего диска), откроется еще одно окно, в котором нажимаем на «Записать» и ждем окончания процесса записи.

в) https://primtrud.ru/content/tehnika-bezopasnosti-pri-rabote-s-kompyuterom.html - правила работы за компьютером


На цифровом диктофоне имеется аудиозапись выступления. Необходимо сделать фоновое музыкальное сопров
0,0(0 оценок)
Ответ:
hickov2003
23.12.2020 19:42

#include <iostream.h>

 

bool amafree(float x1, float x2, float x3, float x4, float y1, float y2, float y3, float y4, float dotx, float doty)

 

{float x[4],y[4],temp;

for(int i=0;i<4;i++)

for(int j=0;j<3;j++)

{

       if(x[j]<x[j+1])

       {

                    temp=x[j];

                    x[j]=x[j+1];

                    x[j+1]=temp;  

                    temp=y[j];

                    y[j]=y[j+1];

                    y[j+1]=temp;  

                      }

       }

 

if (y[2]<y[3]) {temp=x[2];

                    x[2]=x[3];

                    x[3]=temp;  

                    temp=y[2];

                    y[2]=y[3];

                    y[3]=temp;  }//теперь мы упорядочили точки прямоугольника, чтобы понимать его как у меня на рисунке

    x1=x[0];

    x2=x[1];

    x3=x[2];

    x4=x[3];

    y1=y[0];

    y2=y[1];

    y3=y[2];

    y4=y[3];//так мне удобнее, потому что часть условий уже написал без всяких массивов

     

    float k[10];

    k[0]=(x1-x2)/(y1-y2);

    k[1]=(x1-x3)/(y1-y3);

    k[2]=(x3-x4)/(y3-y4);

    k[3]=(x2-x4)/(y2-y4);//коэффициенты прямых, проходящих по сторонам прямоугольника

 //   if(k[0]!=k[2]||k[1]!=k[3]) {cout<<"Eto dazhe ne parallelogramm\n";return false;}//условие параллельности противолежащих сторон

  //   if(k[0]!=1/k[1]||k[2]!=1/k[3]) {cout<<"Eto dazhe ne pryamougolnik\n";return false;}//условие перпендикулярности смежных сторон

    if(dotx<x[1])&&(dotx<x[2])&&(dotx<x3)&&(dotx<x4)||(doty<y1)&&(doty<y2)&&(doty<x3)&&(doty<x4)||//лежит точно вне

    (dotx>1)&&(dotx>x2)&&(dotx>x3)&&(dotx>x4)||(doty>y1)&&(doty>y2)&&(doty>x3)&&(doty>x4)||//лежит точно вне

    (dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[0]*dotx<0)||//нижний левый треугольник

    (dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[1]*dotx>0)||//верхний левый

    (dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[2]*dotx>0)||//верхний праввый

    (dotx>x1)&&(dotx<x2)&&(dotx<x3)&&(dotx<x4)&&(doty-k[3]*dotx<0)//нижний правый

    return false;

    return true;

    }

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота