Шакира228
21.10.2022 01:14

C++ напишите программу, которая сравнивает количество перестановок при сортировке одного и того же массива разными

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
may12312
04.02.2021 23:06

Программа

 {

покажись;

в_точку ( -125 ,-100 );

опусти_перо;

вперед ( 100 );

вправо ( 90 );

вперед ( 50 );

вправо ( 90 );

вперед ( 100 );

подними_перо;

в_точку ( -55 ,-50 );

опусти_перо;

вперед ( 50 );

влево ( 90 );

вперед ( 27 );

влево ( 90 );

вперед ( 50 );

влево ( 90 );

вперед ( 27 );

подними_перо;

 в_точку ( -10 ,-100 );

 опусти_перо;

 вправо ( 105 );

 вперед ( 52 );

 вправо ( 150 );

 вперед ( 52 );

 вправо ( 15 );

 подними_перо;

 в_точку ( 35 ,-50 );

 опусти_перо;

 вперед ( 50 );

 влево ( 150 );

 вперед ( 54 );

 вправо ( 150 );

 вперед ( 50 );

 подними_перо;

 в_точку ( 80 ,-50 );

 опусти_перо;

 вперед ( 50 );

 влево ( 180 );

 вперед ( 25 );

 вправо ( 90 );

 вперед ( 27 );

 влево ( 90 );

 вперед ( 25 );

 влево ( 180 );

 вперед ( 50 );

 подними_перо;

 в_точку ( 125 ,-100 );

 опусти_перо;

 вправо ( 195 );

 вперед ( 52 );

 вправо ( 150 );

 вперед ( 52 );

 вправо ( 15 );

 влево ( 90 );

 подними_перо;

 в_точку ( 125 ,-75 );

 опусти_перо;

 вперед ( 27 );

 подними_перо;

 в_точку ( 175 ,-100 );

 }


Напишите, , с исполнителя черепашка имя «полина», подробно со всеми действиями (вправо, опустить хво
0,0(0 оценок)
Ответ:
Ekaterina200130
12.10.2022 01:12

Program n_1;

var i, b, k:integer; a: array [1..2000] of integer;

begin

   writeln('Введите числа');

   for i:=1 to 2000 do read(a[i]);

   writeln;

   writeln ('Числа, состоящие из 2 разрядов:');

   for i:=1 to 2000 do begin

       b:=a[i];

       k:=0;

       while b>0 do

           begin

           b:=b div 10;

           k:=k+1;

       end;

       if k=2 then write(a[i], ' ');

   end;

   writeln;

   writeln ('Числа, состоящие из 3 разрядов и кратные 3:');

   for i:=1 to 2000 do begin

       b:=a[i];

       k:=0;

       while b>0 do

           begin

           b:=b div 10;

           k:=k+1;

       end;

       if k=3 then begin

           b:=(a[i] mod 10) + ((a[i] div 10) mod 10) + ((a[i] div 100) mod 10);

           if (b mod 3) = 0 then write(a[i], ' ');

       end;

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота