igorlevocko
15.06.2021 09:37

Написать программу, которая получает два числа и выписывает все числа между ними
Ввести натуральное число N и вывести все натуральные числа, не
превосходящие N и делящиеся на каждую из своих цифр. (Например, 15 делится на 1 и на

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
qq302894
24.10.2022 10:04
Var
n,t,s,d,e:integer;
begin
writeln('');
repeat
writeln('Введите сумму в рублях<=1000');
readln(n);
until (n>0) and (n<=1000);
t:=n div 1000;
n:=n-t*1000;
s:=n div 100;
n:=n-s*100;
d:=n div 10;
if d<>1 then
begin
n:=n-d*10;
e:=n;
end;
case t of
     1:write('тысяча ');
end;
if s>=0 then
case s of
     1:write('сто ');
     2:write('двести ');
     3:write('триста ');
     4:write('четыресто ');
     5:write('пятьсот ');
     6:write('шестьсот ');
     7:write('семьсот ');
     8:write('восемьсот ');
     9:write('девятьсот ');
end;
if d>=0 then
case d of
     1:
     case n of
     10: write('десять ');
     11: write('одиннадцать ');
     12: write('двенадцать ');
     13: write('тринадцать ');
     14: write('четырнадцать ');
     15: write('пятнадцать ');
     16: write('шестнадцать ');
     17: write('семнадцать ');
     18: write('восемнадцать ');
     19: write('девятнадцать ');
     end;
     2:write('двадцать ');
     3:write('тридцать ');
     4:write('сорок ');
     5:write('пятьдесят ');
     6:write('шестьдесят ');
     7:write('семьдесят ');
     8:write('восемьдесят ');
     9:write('девяносто ');
end;
if e>=0 then
case e of
     1:write('один ');
     2:write('два ');
     3:write('три ');
     4:write('четыре ');
     5:write('пять ');
     6:write('шесть ');
     7:write('семь ');
     8:write('восемь ');
     9:write('девять ');
end;
if (e=1) then write('рубль ')
else if (e=0)or(e>4) then write('рублей ')
else write('рубля ');
end.
0,0(0 оценок)
Ответ:
nail18121
05.11.2022 20:55
Const
  n = 50;

var
  a: array[1..n] of integer;
  i, min: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  min:=32767;
  for i := 1 to n do
  begin
    a[i] := Random(99)+1;
    Write(a[i]:3);
    if ((a[i] mod 2)<>0) and (min>a[i]) then min:=a[i]
  end;
  Writeln;
  Writeln('Минимальный нечетный элемент равен ',min)
end.

Тестовое решение:
Исходный массив
 24 19 87 17 11 98 74 11 57 42  9 23  3 90 62 61 53 55 63 93 22 50 82 97 26 39 43 26 46 52 13 94 26 98 87 95 43 69 24 41 56 78 22 45 53 45 59 57  3 64
Минимальный нечетный элемент равен 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота