marshmelloy36
11.03.2022 16:38

Нужна по информатике! Нужно составить программу в Паскаль АБС, где в числах от 4 до 11 будет выводится их куб нужно!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
8Мария11
22.05.2023 04:48
Переводим 3 байт обоих адресов в двоичную систему счисления
152(10) = 10011000(2)
157(10) = 10011101(2)

Запишем их друг под другом

10011000
10011101

Нам нужен наибольший байт маски. В маске под единицами записывается адрес сети, под нулями - номер хоста. Адрес сети у этих адресов одинаковый, то есть для поиска наибольшего байта маски мы можем байты разделить так
10011   000
10011   101

Первые пять разрядов - это окончание адреса сети, последние три - начало хоста. Хосту в маске подсети соответствуют нули, адресу сети - единицы, получается, что наибольший байт маски равен

10011   000
10011   101
11111   000 - маска

11111000(2) = 248(10)
0,0(0 оценок)
Ответ:
gmunaitbas
01.08.2022 04:35

Задача 1

var

 y, x: integer;// Объявляем переменные типа Integer

begin// Начало блока

 writeln('Введите X: '); //Выводим текст на экран

 read(x); //Читаем значение введеное с кливиатуры и записываем его в переменную

 y := 7 * x * 2 - 3 * x + 6; //Выолняем выражение

 writeln('Результат: ', y);// Выводим результат

end. // конец блока

Задача 2:

var

 a, b, c: integer;//Объявление переменных

begin

 write('Введите длину ребра куба '); //Вывод текста на экран

 read(a); //Читаем значение введеное с клавиатуры

 b := a * a * a; //Вычисляем объем куба

 c := 6 * sqr(a); //Sqr - квадрат числа

 {Далее опять же вывод результата}

 writeln('Объём куба равен ', b);

 writeln('Площадь боковой поверхности куба равна ', c);

end.

Задача 3

var

 k: integer;//Объявление переменных

begin

 write('Введите число: '); //Вывод текста на экран

 read(k); //Читаем значение введное с клавиатуры

 if Odd(k) then //Odd - возвращает True - если значение нечетно и False если четно

   writeln('Нечетное')

 else

   writeln('Четное');

end.

Задача 4:

var

 a, b: integer;

begin

 writeln('Введите a и b через пробел:');

 readln(a, b);

 if (b mod a = 0) then writeln('Число ', a, ' является делителем числа ', b)  

 else writeln('Число ', a, ' НЕ является делителем числа ', b);

end.

Задача 5:

var

 a, b: real;

begin

 writeln('Через пробел введите 2 числа: ');

 read(a, b);

 if a > b then //Условие если А больше Б

 begin

   a := a / 2; //Делим число А на 2 и выводим результат

   writeln('A:= ', a, ' B:= ', b);

 end

 else //Иначе оставляем все как и было

   writeln('A:= ', a, ' B:= ', b);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота