хики2
09.02.2023 14:15

1)составить программу которая находит наименьшую сумму ряда 3+4+5+6+ превышающую число 15. 2) составить программу, которая находит наименьшую сумму ряда 3+6+12+24+ превышающую введённое число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
woof1337
11.06.2022 18:48

Комментарий:

Да условие не до конца дописано, но с таким началом условия скорее всего это задача:

определите значение переменной s после выполнения следующего фрагмента программы: s:= 0; for i:=1 to 9 do  if A[i - 1] < A[i] then begin  s := s + 1; t := A[i];  A[i] := A[i - 1];  A[i - 1] := t  end;

Незачем считать, хотя и можно, проще просто запустить этот код:

var a: array [0..9] of integer = (1, 2, 4, 3, 5, 6, 8, 7, 3, 4); i, t, s: integer; begin s := 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end; write(s); end.

Как мы видим, после выполнения данного в условии фрагмента переменная s будет равна 9.


В программе используется одномерный целочисленный массив а с индексами от 0 до 9. значения элементов
0,0(0 оценок)
Ответ:
Salekhova58
13.09.2021 19:49

Объяснение:

1. Программное обеспечение – это:

2) совокупность программ установленных на компьютере

2. Что не является объектом операционной системы Windows:

3) Процессор

3. Какое действие нельзя выполнить с объектом операционной системы Windows:

4) Порвать

4. Файл – это:

4) программа или данные на диске

5. Операционная система – это:

3) набор программ, обеспечивающий работу всех аппаратных устройств компьютера и доступ пользователя к ним

6. Что такое буфер обмена:

1) специальная область памяти компьютера, в которой временно хранится информация

7. Какие функции выполняет операционная система:

4) организация диалога с пользователем, управления аппаратурой и ресурсами компьютера

8. Операционная система относится к:

2) системному программному обеспечению

9. Графическим редактором называется программа, предназначенная для:

3) работы с графическим изображением

10. Для удаления символа справа от курсора используется клавиша:  3) Delete

11. Текст, набранный в тестовом редакторе, хранится на внешнем запоминающем устройстве:

1) в виде файла

12. Текущий диск – это

2) диск, с которым пользователь работает в данный момент времени

13. Какой из подключения к Интернет обеспечивает наибольшие возможности для доступа к информационным ресурсам:

4) постоянное соединение по оптоволоконному каналу

14. Для удаления символа слева от курсора используется клавиша:

2) Backspace

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота