yyyoooppp
13.11.2021 16:40

Задание 3
Чему равно значение s после выполнения цикла
Program T3;
var s,k: integer;
begin
s := 2;
for k := 1 to 3 do
s := s * s;
writeln(s);
end.
Задание 4
Чему равно значение s после выполнения цикла
Program T4;
var s,n: integer;
begin
s := 0;
for n := 3 to 7 do
s := s + 2*n;
writeln(s);
end.
Задание 5
Чему равно значение s после выполнения цикла
Program T5;
var s,k: integer;
begin
s := 0;
for k := 6 to 12 do
s := s + 5;
writeln(s);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
svetaalekperova
10.10.2022 14:50

Задача вычисления суммы элементов массива достаточно проста: все элементы массива перебираются и добавляются в одну и ту же переменную. Перебор элементов массива осуществляется в цикле for. Аналогично находится сумма элементов двумерного массива с той лишь разницей, что добавляется вложенный цикл for для прохода по элементам каждой строки матрицы.

Более сложная задача – это найти сумму не всех элементов массива, а только удовлетворяющих какому-нибудь условию или находящихся в определенных местах матрицы.

В программе ниже находится сумма всех элементов массива (переменная sum), а также сумма элементов, составляющих столбцы таблицы (двумерного массива). Для хранения сумм столбцов чисел используется одномерный массив (s).

0,0(0 оценок)
Ответ:
dilya091
10.10.2022 14:50
Var    matrix: array[1..5,1..5] of integer;    i, j: integer; sg:=0; sp:=0;begin    writeln ('Введите 25 чисел: ');     for i := 1 to 5 do        for j := 1 to 5 do            read (matrix[i,j]);     for i := 1 to 5 do begin        for j := 1 to 5 do            write (matrix[i,j], ' ');        writeln    end;  for i:=1 to 5 do begin   for j:= 1 to 5 do   if j=i then sg:=sg+matrix[i,j]; end; for i:=5 downto 1 do    begin    for j:=1to 5 do    if (i+j)=6 then sp:=sp+matrix[i,j]    end;    sp:=sp-matrix[3,3];1 writeln(sg,' ',sp);readlnend
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота