оля1441
28.03.2020 09:26

2. В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной a после выполнения алгоритма:

а := 5
b := 4
b := 100 - a*b
a := b/16*a

В ответе укажите одно целое число — значение переменной a.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
34we523
05.04.2023 05:19

 

  uses   crt;   var   a: array [1..20, 1..20] of real;   i, j, k, n, s: integer;   begin   clrscr;   write('Введите размер матрицы: ');   read(n);   for i := 1 to n do     for j := 1 to n do     begin       write('A[', i, ',', j, ']= ');       readln(a[i, j]);     end;   WRITELN;   WRITELN;   writeln('Исходная матрица ', n, 'x', n, ': ');   for i := 1 to n do   begin     for j := 1 to n do       WRITE(a[i, j]:2:0, ' ');     WRITELN;   end;   k := 0;   for i := 1 to n do   begin     for j := 1 to n do     begin       if a[i, j] = 0 then       begin         k := k + 1;         s := s + 1;       end;     end;     if k = n then writeln(i, ' строка состоит из нулей! ');     k := 0;   end;   if s = 0 then writeln('В матрице нет нулевых строк'); end.
0,0(0 оценок)
Ответ:
vikki01092
16.06.2022 23:39
ОК, всё это циклы.
1) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик увеличивается на 1. Пример:
for a:=1 to 10 do //Цикл будет выполнен 10 раз
2) Цикл for (цикл с счётчиком), при этом при каждом шаге цикла счётчик уменьшается на 1. Пример:
for a:=10 to 1 do //Цикл будет выполнен 10 раз
3)Цикл с постусолвием. Если условие не выполняется, выполняется цикл. Его особенность заключается в том, что цикл выполнится хотя бы один раз вне зависимости от условия. Пример:
k:=0;
repeat
inc(k);
until k<9 //10 раз
4)Цикл с предусловием. Пока условие выполняется, выполняется и цикл.
Пример:
k:=0;
while k<>10 do
inc(k); //10 раз
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота