Вычислить сумму элементов массива N раз¬мерности 4×5 элементов, находящихся в четных строках. написать программу в C++ и сделать блок-схему. Сделать по примеру ниже
Когда что то качается, то обычно показывается не только скорость но и время до конца скачивания (при данной скорости), так что само значение скорости нужно только чтоб видеть увеличивается скорость, уменьшается или стабильна.
для размеров файлов 1 бит это одна ячейка, которая может быть или 0 или 1 1 б(байт) = 8 бит 1 Кб (килобайт) = 1024 б 1 Мб (мегабайт) = 1024 Кб 1 Гб (гигабайт) = 1024 Мб Для практического использования данных знаний вполне достаточно Если же интересно покопаться, то на самом деле есть килобайты и кибибайты и они отличаются, потому что кило = 1000, а киби = 2^10 = 1024.
Если говорить о скорости, то она стандартно считается в битах, килобитах, мегабитах и тд. Т.е. в 8 раз меньше соответственно байта, килобайта, мегабайта и тд. Но для практического использования это все не нужно)
Var m : array[0..6] of Integer; i,k,N : Integer; Begin For i:=0 to 6 do m[i]:=0; Readln(N); k:=6; While N>0 do Begin If N>=Power(2,k) then Begin N:=N-Trunc(Power(2,k)); Inc(m[k]); end else Dec(k); end; For i:=0 to 6 do Writeln(Power(2,i),' ',m[i],' шт.'); end.
Еще вариант: Const NN = 7; money : array[1..7] of Integer = (1,2,4,8,16,32,64); Var m : array[1..NN] of Integer; i,k,N : Integer; Begin For i:=1 to NN do m[i]:=0; Readln(N); k:=NN; While N>0 do Begin If N>=money[k] then Begin N:=N-money[k]; Inc(m[k]); end else Dec(k); end; For i:=1 to NN do Writeln(money[i],' ',m[i],' шт.'); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку