sashamakarova30
25.05.2020 07:18

Задача 1. Создать программу для формирования таблицы умножения (таблицы Пифагора).
Program Piphagor;
Uses crt;
var i,j:byte;
a: array [1..9, 1..9] of integer;
begin
clrscr;
{шапка таблицы Пифагора}
for i:=1 to 9 do write(i:3,' |'); writeln;
for i:=1 to 9 do write('+'); writeln;
{сама таблица}
for i:=2 to 9 do
begin
for j:=1 to 9 do
begin
a[i,j]:=i*j;
write(a[i,j]:3,' |');
end;
writeln;
end;
readln;
end.

Пример № 2.
Составить программу, которая в двумерном массиве случайных чисел находит в каждой строке наибольший элемент и записывает его в одномерный массив.
m – количество строк в двумерном массиве и длина одномерного массива;
n – количество столбцов;
A[1..m,1..n] - двумерный массив;
B[1..m] – одномерный массив
max – вс переменная для нахождения наибольшего элемента в каждой строке.

Program max_str;
Uses crt;
сonst
m=5;
n=6;
var i,j:byte;
a: array [1..m, 1..n] of integer;
b: array [1..m] of integer;
max: integer;
begin
clrscr;randomize;
for i:=1 to m do
begin
for j:=1 to n do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
writeln;
end;
writeln ('Массив из максимальных значений в строках:');
for i:=1 to m do
begin
max:=a[i,1];
for j:=2 to n do
begin
if a[i,j]>max then max:=a[i,j];
end;
b[i]:=max;
write (b[i]:4);
end;
readln;
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Supreme222
20.04.2020 11:17
1.трудно воспринимать текст, написанный в разных стилях.  2. готовый вид документа с определенными полями  3. при оформлении официальных документов (шапка, заголовок, основное содержание)4.шрифт times new roman подходит как и для основного текста, так и для заголовков. заголовки лучше набирать полужирным шрифтом, но можно и курсивом .5. открываем word и находим вкладку верхнего меню «рассылки». переходим в нее и видим, что первая слева группа команд называется «создание» и содержит две кнопки: «конверты» и «наклейки». нас интересуют именно шаблон конверта в word, так то кликаем по этой кнопке.6.при кнопки список   в этом редакторе можно  составить маркированные и нумерованные списки. такая кнопка есть  в процессоре  ms  word , она находится на вкладке ленты  главная . 7. маркерованные это символы и картинки, нумерованные 1,2,3,,а,б,,б,.b.,b,c ,ii,,ix,xv 1-й,2-,и.т.д8. списки которые смешанные, имеют и маркерованные и нумерованные.9.вставка-- рисунок или просто перетащить из папки.вставка --формулавыделить объект-- правая кнопка мыши--гиперссылка10.к огда информация состоит из множества данных, которые модно груаппировать по какому-либо признаку на несколько
0,0(0 оценок)
Ответ:
Профессионал228
16.05.2022 16:50

ответ:

представители профессии электромонтера являются достаточно востребованными на рынке труда. несмотря на то, что вузы выпускают большое количество специалистов в этой области, многим компаниям и на многих предприятиях требуются квалифицированные электромонтеры.

объяснение: большинство опрошенных считает, что профессию электромонтера нельзя назвать редкой, в нашей стране она достаточно распространена. уже несколько лет на рынке труда наблюдается спрос на представителей профессии электромонтера, несмотря на то, что специалистов каждый год выпускается немало.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота