veronika1217
21.11.2021 16:15

Ребят, очень нужна Написать программу перевода целого числа из 10с.с. В 2с.с.
(Паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nazar0905
14.10.2020 17:34

program ss102;

var a,b,c,i,v:integer;

begin

readln(a);

v:=0;

b := a;

while a > 0 do begin

b = b div 10;

c = c + 1;

end;

for i:=0 to c do begin

b:=a mod 2;

a:=(a-b) div 2;

v:=v + b*exp(i*In(10));

end;

writeln(c);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота