Asherok
25.09.2020 04:27

Pascal. 1. составить программу нахождения произведения двух наибольших из трех введенных с клавиатуры чисел. 2. а) найти сумму нечетных делителей натурального числа. б) для каждого числа от а до в найти сумму его нечетных делителей.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MASTER2008
08.06.2020 21:23
1.

program raf105;

var a,b,c:integer;

begin

write('Введите 3 числа: ');

readln(a,b,c);

if (a<b) and (a<c)

 then writeln('Произведение 2 наибольших чисел: ',b*c);

if (b<a) and (b<c)

 then writeln('Произведение 2 наибольших чисел: ',a*c);

if (c<b) and (c<a)

 then writeln('Произведение 2 наибольших чисел: ',b*a);

end.

2.а)

program raf105;

var a,i,b:integer;

begin

write('Введите число: ');

readln(a);

for i:=1 to a do

 if ((a mod i)=0) and ((i mod 2)<>0)

   then b:= b+i;

writeln('Сумма нечётных делителей введённого числа: ',b);

end.

б)

program raf105;

var a,a2,i,j,b:integer;

begin

write('Введите меньшее число: ');

readln(a);

write('Введите большее число: ');

readln(a2);

for j:=a to a2 do

begin

 for i:=1 to j do

   if ((j mod i)=0) and ((i mod 2)<>0)

     then b:= b+i;

writeln('Сумма нечётных делителей числа ',j,' равна: ',b);

b:= 0;

end;

end.

Язык программирования PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота