шахид2
19.10.2021 05:12

Написать программу на с++ создание модуля генератор. генератор должен циклически по истечении заданного периода времени генерировать от 1 до 3 данных. идентификаторы этих данных выбираются случайным образом из диапазона значений 0; 99. штампу времени присваевается время генерации данных. численное значение данных формируется случайным образом из диапазона -100; 0; 100; 0. код качества устанавливается в 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
atamanova91
06.02.2020 21:23
1.

Нам дана строка из двух слов. Например, 'ah-ha nanana'. Сначала найдем индекс пробела в этой строке. Это делает функция pos(s1, s). Она возвращает первый встретившийся индекс подстроки s1 в строке s. Если мы вызовем pos(' ', 'ah-ha nanana'), она вернет 6. Сохраним это значение в переменную space.

Функция copy(s, pos, n) возвращает подстроку строки s из n символов, которая начинается в pos. Для копирования первого слова нам нужно взять подстроку, которая начинается с первого символа и имеет длину space-1. Под номером space в строке находится пробел, а в space+1 - начало второго слова.

Таким образом, copy('ah-ha nanana', 1, space-1) вернет 'ah-ha', а copy('ah-ha nanana', space+1, length('ah-ha nanana')-space) - 'nanana'.


var

 s, s1, s2: string;

 space: longint;

begin

 readln(s);

 space := pos(' ', s);

 s1 := copy(s, 1, space - 1);

 s2 := copy(s, space + 1, length(s) - space);

 s := s2 + ' ' + s1;

 writeln(s);

end.


2.

Предположим, что первая введенная строка - самая длинная. Если вторая строка длиннее первой, изменим ответ. Если третья строка длиннее самой длинной из первых двух, изменим ответ.

Примечание: В переменной s мы сначала храним первую введенную строку, а после ввода - максимальную. Если нужно сохранить первую введенную строку, лучше хранить максимальную в отдельной переменной.

var

 s, s1, s2: string;

begin

 readln(s);

 readln(s1);

 readln(s2);

 if length(s1) > length(s) then s := s1;

 if length(s2) > length(s) then s := s2;

 writeln(s);

end.

0,0(0 оценок)
Ответ:
натик2017
01.10.2020 20:13

На Visual Basic так:

Нужно на форме создать текстовое поле TextBox1 и кнопку Button1, на нее повесить такую программу:

Sub Button1_Click()

Dim A() As Integer, B() As Integer, C()  As Integer ' динамич. массивы

Dim n As Integer, i As Integer, Txt As String

n = InputBox ("Введите размер массивов")

ReDim A(n), B(n), C(n) ' Определяем размеры массивов

Txt = ""

For  i = 1 To n

A(i) = InputBox ("Введите " & i & "-ый элемент массива A")

B(i) = InputBox ("Введите " & i & "-ый элемент массива B")

C(i) = A(i)^2 + B(i)^2 ' Присваиваем элементу C(i) сумму квадратов

Txt = Txt & C(i) & "; " ' Добавляем C(i) в текстовую переменную

Next i

TextBox1.Text = Txt ' Выводим весь массив C(i) в текстовое поле

End Sub

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота