alexandrasharapova
28.01.2021 17:30

Решить Pascal. На листке. Именно на листке,как задачу
Задача 1. Написать программу, выводящую на экран в столбец все чётные числа из промежутка от 100 до 150.

Задача 2. Написать программу, выводящую на экран в столбец все целые числа из промежутка от 100 до 999, которые делятся на число 11.
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
annykovaleva
01.06.2021 20:56

7,6 Кбайт/сек

Объяснение:

V = K * i, где  

V - информационный объём изображения (размер файла, содержащего изображение)

K - количество точек (пикселей )

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

N = 2^i, где  

N - количество цветов в палитре

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

^ - знак степени

V = q * t  , где

V - объем переданной информации

q  - скорость соединения (пропускная канала, в битах в секунду или подобных единицах)

t - время передачи

Дано:

N = 8192

K = 800 х 600 = 480 000

t = 100 секунд

Найти:

q

N = 2^i

2^i = 8192

i = 13 бит (найдено подбором степени)

V = K * i

V = 480 000 * 13 = 6 240 000 бит

V = q * t

q = V / t

q = 6 240 000 / 100 = 62 400 бит/сек

q = 6 240 000 / 100 = 62 400 бит/сек = 62 400 / 8 = 7 800 байт/сек = 7,6171875 Кбайт/сек ≈ 7,6 Кбайт/сек

0,0(0 оценок)
Ответ:
Нурсая12345
13.06.2021 14:34

Объяснение:

Эта задача сводится к задаче поиска пути на графе пространства состояний.

Состояние - положение черепашки на поле - (x, y).

Граф пространства состояний состоит из таких вершин-состояний, их количество N * M.

Переходов между вершинами всего два: R и D.

Здесь можно заметить, что прийти к одним и тем же вершинам мы можем разными путями. Например, путь из (0,0) в (1,1) можно расписать и как RD ((0,0) -> (0,1) -> (1,1)), и как DR ((0,0) -> (1,0) -> (1,1)), но это два разных маршрута.

Однако при неизменном ценовом листе максимальная стоимость и оный маршрут в любой клетке поля значение строго определённое и неизменное во времени.

Это значит, что нам не нужно рассчитывать результат для одинаковых состояний больше одного раза, так как они будут совпадать.

Итак, для каждого состояния у нас есть два правила перехода. Рассчитывая максимальную стоимость маршрута для состояния (x,y) мы следуем алгоритму:

Если можем идти вправо, рассчитываем параметры для этого маршрутаЕсли можем идти вниз, рассчитываем параметры для этого маршрутаВыбираем между путями, если можем идти, или стоим, если уже не можемК выбранному варианту добавляем параметры текущего состояния

Если такой алгоритм применить к состоянию (0,0), то дойдем до (N, M) и получим максимальную цену и маршрут.

Код:

import re

from typing import List

cache = {}

def calculate_max_way_price(x: int, y: int, prices: List[List[int]], m:int, n:int):

   if (x, y) in cache:

       return cache[(x, y)]

   direction = ''

   cost = prices[y][x]

   x_cost, y_cost = -1, -1

   x_way, y_way = '', ''

   if x < m - 1:

       x_cost, x_way = calculate_max_way_price(x + 1, y, prices, m, n)

   if y < n - 1:

       y_cost, y_way = calculate_max_way_price(x, y + 1, prices, m, n)

   if not (x_cost < 0 and y_cost < 0):

       if x_cost > y_cost:

           cost += x_cost

           direction = 'R' + x_way

       else:

           cost += y_cost

           direction = 'D' + y_way

   cache[(x, y)] = (cost, direction)

   return cost, direction

MNtext = input('Enter N M: ')

MN = [int(x) for x in re.findall(r'\d+', MNtext)]

if len(MN) != 2:

   print("Input data error! It is not M and N")

   exit(-1)

N, M = MN[0], MN[1]

MAX_STEP_PRICE = 100

data = input('Enter all numbers separated by spaces. You must type ' + str(M*N) + ' elements:')

data = [int(x) for x in re.findall(r'\d+', data)]

if len(data) != N * M:

   print("Input data error! Too few/many numbers")

   exit(-2)

prices = []

for j in range(N):

   prices.append(data[M*j:M*(j+1)])

print(calculate_max_way_price(0, 0, prices, M, N))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота