pugovka2017
03.11.2020 13:35

Напишите программу, которая проверяет, является ли введенная строка десятичным числом (на c)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
нор123456789
21.09.2021 11:20

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

0,0(0 оценок)
Ответ:
irynasherem02
22.07.2021 22:10

#include - подключение библиотеки.

using namespace std; - объявление пространства имен

void swap(int x, int y, int z) - определение функции swap, которая ничего не возвращает, с принимаемыми аргументами типа int. Служит для обмена значений

{} - операторные скобки

int temp - объявление локальной переменной temp.

if(x > y ) - Если x > y, мы меняем значения x и y. temp - промежуточная переменная для хранения значения.

if(x > z) - Если x > z, мы меняем значения x и z. temp - промежуточная переменная для хранения значения.

if(y > z) - Если y > z, мы меняем значения y и z. temp - промежуточная переменная для хранения значения.

cout << x << " " << y << " " << z << "\n"; - вывод переменных x y z через пробел. \n - перевод каретки на новую строку.

}

int main() - главная функция, которая начинает свое выполнение при запуске

{

int x = 2, y = 6, z = 5; - определение переменных x y z

swap(x, y, z); - вызываем функцию и передаем ей значения x y z

system("pause >> null"); - передача команды "pause >> null" командному процессору. Тормозим выполнение программы. >> null означает, что не будет ничего написано. (Без этого будет писать, в роде: Для продолжения нажмите")

return 0; - возвращаемое значение

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота