дана396
15.11.2020 17:21

Вам необходимо составить программу, которая будет пользователя заполнить массив целых чисел состоящий из 20 элементов. Далее программа должна найти наименьший и наибольший элемент массива и вывести на экран среднее арифметическое этих.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Rianariana2002
21.07.2020 00:31
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк/столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(n,n,1,50);
  a.Println(3); Writeln(3*a.ColCount*'-');
  // начало расчетов
  var s:=0;
  for var i:=0 to n-1 do s+=a[i,n-i-1];
  Writeln('1: S=',s);
  Write('2: Суммы построчно: '); a.Rows.Select(row->row.Sum).PrintLn;
  Write('3: Произведение элементов: ');
  a.ElementsByRow.Aggregate(BigInteger(1),(p,q)->p*q).PrintLn;
  var p:BigInteger:=1;
  for var i:=0 to n-1 do p*=a[i,i];
  Writeln('4: П=',p);
end.

Необходимо решение по икт pasckal 10 ! используя только знания 10 класса. 1) найти сумму элементов п
0,0(0 оценок)
Ответ:
KKnoneTT
19.10.2022 18:01
//Pascal
var
  A: array [1 .. 5, 1 .. 4] of integer;
  V: array [1 .. 20] of integer;
  i, j, z: byte;
  SUM1, SUM2, SUM3, MIN: integer;
begin
  randomize;
  writeln('***Сгенерированный массив***');
  SUM1 := 0; SUM2 := 0; SUM3 := 0;
  for i := 1 to 5 do
  begin
    for j := 1 to 4 do
    begin
      A[i, j] := random(30);
      if ((A[i, j] >= 0) and (A[i, j] <= 5)) then SUM1 := SUM1 + A[i, j];
      if ((A[i, j] >= 5) and (A[i, j] <= 15)) then SUM2 := SUM2 + A[i, j];
      write(A[i, j]:6)
    end;
    writeln;
  end;
  writeln('Сумма элементов [0 5] = ', SUM1);
  writeln('Сумма элементов [5 15] = ', SUM2);
  MIN := A[3, 1];
  for j := 1 to 4 do if A[3, j] < MIN then MIN := A[3, j];
  writeln('Минимальный элемент в третьей строке = ', MIN);
  writeln('***Вектор***');
  j := 1;
  z := 0;
  while (z < 20) do
  begin
    for i := 1 to 5 do
    begin
      z := z + 1;
      V[z] := A[i, j];
    end;
    j := j + 1;
  end;
  for i := 1 to 20 do writeln(V[i]:6);
  for i := 20 downto 10 do SUM3 := SUM3 + V[i];
  writeln('Сумма последних 10-ти элементов = ', SUM3);
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота