alena0bashinskaya
12.03.2021 14:16

Написать программу нахождения суммы натуральных чисел оканчивающихся на 7, среди чисел введённых пользователем, признак окончания ввода чисел ввод числа 0.(используем цикл repeat)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
altunbaevmax
27.02.2022 00:50
Анализ (др.-греч. ἀνάλυσις — разложение, расчленение) — метод исследования, характеризующийся выделением и изучением отдельных частей объектов исследованияОбъект в программировании — некоторая сущность в виртуальном пространстве, обладающая определённым состоянием и поведением, имеющая заданные значения свойств (атрибутов) и операций над ними (методов)[1]. Как правило, при рассмотрении объектов выделяется то, что объекты принадлежат одному или нескольким классам, которые определяют поведение (являются моделью) объекта. Термины «экземпляр класса» и «объект» взаимозаменяемы.[2]
Мышле́ние (гр. ноэзис) — это познавательная деятельность человека[1]. Результатом мышления является мысль (понятие, смысл, идея). Мышление противопоставляют «низшим освоения мира в форме ощущенияили восприятия, которые свойственны в том числе и животным. Многие философы называли мышление сущностным свойством человека. Так Декартутверждал: «Я мыслю, следовательно, я существую». Паскаль называл человека мыслящим тростником[2]Ло́гика (др.-греч. λογική — «наука о правильном мышлении», «искусство рассуждения» от λόγος — «речь», «рассуждение», «мысль») — раздел философии, нормативная[неизвестный термин][1] наука о формах, методах и законах  деятельности, формализуемых с языка. Поскольку это знание получено разумом, логика также определяется как наука о формах и законах правильногомышления. Поскольку мышление оформляется в языке в видерассуждения, частными случаями которого являютсядоказательство и опровержение, логика иногда определяется как наука о рассуждения или наука о доказательств и опровержений. 
0,0(0 оценок)
Ответ:
vikaberg
15.05.2022 01:45
1) а) на Java
class example{
    public static void main (String[] args){
        int k = 0, j = 0;
        for (int i = 0; i < 10; i++){
            k = k + 5;
            j = j + k;
            if (i == 9)
            System.out.print(k);
            else
            System.out.print(k + " + ");
        }
        System.out.print(" = " + j);
    }
}
б) на Pascal
var a,b,c:integer;
begin
for a:=1 to 10 do
begin
b:=b+5;
c:=c+b;
if (a = 10) then write(b)
else write(b, ' + ')
end;
write(' = ', c);
end.
2) а) на Java
class example{
    public static void main(String args[]){
        for (int x = 50; x >= 40; x--){
        double y = (5 * x) + (Math.pow(x, 2));
        int i = (int) y;
        System.out.println(i);
        }
    }
}
б) на Pascal
var y:real;
x:integer;
begin
for x:=50 downto 40 do
begin
y:=(5*x)+sqr(x);
writeln(y:0:0);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота