lenusyamailru
04.05.2022 19:26

Дано четырехзначное число, составить программу подсчета количества нечетных цифр в этом числе и сообщение false(если таких цифр нет) и true (если есть).
Питон

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
гот12
06.09.2020 11:27

number = 4222

count = 0

number = str(number)  

number = list(number)

number = map(int, number)

for i in number:

   if i % 2 != 0:

       count += 1

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

number = 4222

count = 0

( c комментариями)

number = str(number)

number = list(number)

number = map(int, number)

# переводим число в список

for i in number:

   if i % 2 != 0:

       count += 1

#находим нечетное число

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

# выводим его

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота