mahomaev
12.03.2021 06:05

ПИТОН! Написать программу, для решения уравнение: Ax=B. Переменные А, B вводятся через клавиатуру через консоль. x-неизвестное. Про область допустимых значений не забываем. Помните, что на ноль делить нельзя. Материал может пригодится

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Алёна542133
19.11.2022 04:17
Var a,b:array [1..100,1..100] of real;
    current_row,current_column,rows,columns:integer;

begin
  readln(rows);
  readln(columns);

  for current_row := 1 to rows do begin
    writeln();
    for current_column := 1 to columns do begin
      read(a[current_row,current_column]);
      b[current_row,current_column] :=a [current_row,current_column] / 8;
    end;
  end;

  for current_row := 1 to rows do begin
    writeln();
    for current_column := 1 to columns do
      write(b[current_row,current_column]:4, ' ');
  end;
end.
0,0(0 оценок)
Ответ:
repkinvasya
19.11.2022 04:17
Описательная часть: все что находится в Var'e
var
a:array [1..100,1..100] of real; - описание двумерного масива
b:array [1..100,1..100] of real; - аналогично
i,m,n,c:integer; - описание переменных целого типа, тип это integer
i
begin - начало исполняемой части
readln(n); - считывает переменную целого типа, кол-во строк матрицы
readln(c); - аналогично, кол-во столбцов матрицы
for i:=1 to n do -цикл для строк
for m:=1 to c do - цикл для столбцов
 readln(a[i,m]); - считывает и записывает в двумерный массив числа
for i:=1 to n do -цикл для строк
for m:=1 to c do - цикл для столбцов
b[i,m]:=a[i,m]/8; - это каждый элемент массива А делит на 8, и присваивает другому массиву
for i:=1 to n do -цикл для строк
for m:=1 to c do- цикл для столбцов
 writeln(b[i,m]); - вывод второго масива
end. - конец исполняемой части
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота