MDA142rus
30.06.2021 17:18

1.Написать программу и записи и ее индекса по введенной фамилии.
2.Написать программу для формирования трех файлов для записи и сохранения информации – фамилия, имя, отчество.
В

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Крутой649
23.07.2021 09:54


1. в случаях, когда надо выполнить не следующий по порядку оператор, а какой-нибудь другой, отмеченный меткой (например выйти из цикла)
4. "следование", "ветвление", "цикл с предусловием"
5.  для осуществления на него безусловного перехода;
6. для вывода графики
7. для очистки экрана
8. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
9. power(x,y)
10. integer
11. :=
12. F9
13. write и writeln
14. Раздел описаний
16.  операторы, не содержащие никаких других операторов    
17. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
18. for; while.. do; repeat...until
19. текстовые файлы; типизированные файлы; нетипизированные файлы
опрераторов if и case of
29.  writeln без параметров
30.  :
31.  закрашивает замкнутую область, используя текущие стиль и цвет закраски.
32.  вывод на экран прямоугольников
33.  Объяснения програмиста.
34.  Никаких действий не выполняет, нужен для осуществления на него безусловного перехода
35.  покомандный анализ, обработку и выполнение исходной программы
36.  Никлаус Вирт в 1968—1969
37.  весь блок, в котором объявлена данная метка, за исключением внутренних блоков
38.  Отметьте, из каких элементов состоит алгоритмический язык?
39.  Program
40.  Var
41.  Set of
42. Шесть: следование; ветвление; цикл с предусловием; цикл с постусловием; цикл с параметром; вариант.
43.  Укажите приоритет операций в языке Паскаль.
44.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
45.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
47.   предложение языка программирования, задающее полное описание некоторого действия, которое может выполнить компьютер
48.   данные, необходимые для выполнения оператора
49.  begin ... end
50.  S - начиная с позиции курсора, выводится значение S (строка или массив символов)
51.  имя метки и двоеточие после него
52.  компилятор - это программа-переводчик, читает всю программу целиком, делает ее перевод и создает законченный вариант программы на машинном языке, который затем и выполняется

0,0(0 оценок)
Ответ:
vanila16
20.07.2020 16:33
ответ: 1909

Var
 s : String;
 n : Integer;
Function IncS(a : String) : String;
Begin
  a[Length(a)]:=Chr(Ord(a[Length(a)])+1);
  If a[Length(a)]>'D' then
    IncS:=IncS(Copy(a,1,Length(a)-1))+'A'
  else IncS:=a;
end;
Function Check(a : String) : Boolean;
Begin
  Check:=False;
  If (Pos('A',a)>0) then
  Begin
    Delete(a,Pos('A',a),1);
    If (Pos('A',a)>0) then Check:=True;
  end;
end;
Begin
  s:=''; n:=0;
  While s<>'' do
  Begin
  {  Writeln(s);  }
    If Check(s) then Inc(n);
    s:=IncS(s);
  end;
  Writeln(n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота