Игорь12463
02.02.2020 22:38

Написать программу для вывода таблицы умножения на заданное число х. Дано: х, i-параметр цикла, а-произведение. Найти:а Связь:а:=х*i Используйте цикл

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Govnoegc
02.12.2021 06:16
Число DCXLI, записанное римскими цифрами, в десятичной системе счисления соответствует числу:
D = 500, С = 100, XL = L - X = 50 - 10 = 40, I = 1
DCXLI = 500 + 100 + 40 + 1 = 641
 
Выберите те числа, в которых есть ошибка:
1902,25 (8) — ошибка, в восьмеричной системе нет цифры 9
12,21 (3) — ок
A6,4 (12) — ок, A = 10
99,99 (9) — ошибка, в девятеричной системе нет цифры 9
 
Алфавит восьмеричной системы счисления записывается так:
{0,1,2,…,7} — для n-ичной системы счисления это цифры от 0 до n - 1.
 
Последовательность знаков числа 11011 (2) в десятичной системе счисления соответствует числу: 
2^4 + 2^3 + 2^1 + 2^0 = 16 + 8 + 2 + 1 = 27 (10)
 
Переведите число 207 (8) в десятичную систему счисления.
207 (8) = 2 * 8^2 + 0 * 8^1 + 7 * 8^0 = 128 + 0 + 7 = 135 (10)
 
Переведите число 18 (10) в двоичную систему счисления.
18 (10) = 16 + 2 = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 0 * 2^0 = 10010 (2)
 
Переведите число 75 (10) в шестнадцатеричную систему счисления.
75 (10) = 4 * 16 + 11 = 4B (16)
 
Греются на солнышке воробьи. На нижней ветке их было 110 (2), на верхней – на 2 (10) меньше. Сколько всего было воробьев?
110 (2) = 2^2 + 2^1 = 5 — на первой ветке
5 - 2 = 3 — на второй ветке
5 + 3 = 8 — всего
 
Укажите основание х системы счисления, если известно, что 29 (10) = 38 (х).
38 (x) = 3 * x + 8 = 29 (10)
3x + 8 = 29
3x = 21
x = 7
0,0(0 оценок)
Ответ:
karina24264
02.12.2021 06:16
Var a:integer;
begin
readln(a)
if a:=1 then writeln('1 - один');
 if a:=2 then writeln('2 - два');
 if a:=3 then writeln('3 - три');
 if a:=4 then writeln('4 - четыре');
. . .{по аналогии}
end.
2)Абсолятно то же самое что и в предыдущем номере, просто тепрь писать 1 - понедельник, 2 - вторник...
3)var a:integer;
if a:=1 then writeln('Sharik');
if a:=2 then writeln('kot');
if a:=3 then writeln('Fedor');
if a:=4 them writeln('Pechkin');
end.
4) и 6) выполняются по аналогии.
Если не понимаешь, я объясню в комментариях.
 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота