Ωμza
24.09.2022 18:09

Написать программы на языке программирования Паскаль.
1. Поменять местами содержимое двух переменных S и T.
2. Найти корни квадратного уравнения ax^2+bx+c=0
3. Найти сумму нечетных чисел натурального ряда от 25 до N/
4. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 4 и оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4 и оканчивающееся на 5. Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести одно число: сумму чисел, кратных 3 и оканчивающихся на 4.
5.Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 5 или 9.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
titan9064
11.12.2022 00:40

Бит | Байт | Кбайт | Мбайт

24576 | 3072 | 3 | 0,003

16384 | 2048 | 2 | 0,002

12288 | 1536 | 1,5 Кбайт | 0,001

67108,864 | 8388,608 | 8,192 | 0,008

Объяснение:

1 байт = 8 бит

1 Кбайт = 1024 байт

1 Мбайт = 1024 Кбайт

24576 бит = 24576 / 8 = 3072 байт = 3072 / 1024 = 3 Кбайт = 3 / 1024 ≈ 0,003 Мбайт

2048 байт = 2048 / 1024 = 2 Кбайт = 2 / 1024 ≈ 0,002 Мбайт

2048 байт = 2048 * 8 = 16384 бит

1,5 Кбайт = 1,5 / 1024 ≈ 0,001 Мбайт

1,5 Кбайт = 1,5 * 1024 = 1536 байт = 1536 * 8 = 12288 бит

0,008 Мбайт = 0,008 * 1024 = 8,192 Кбайт = 8,192 * 1024 = 8388,608 байт = 8388,608 * 8 = 67108,864 бит

0,0(0 оценок)
Ответ:
tlplusp02d7u
11.12.2022 00:40

# 1

print('1)')

num = int(input('Введите число: '))

print(str(num).count('3'))

# 2

print()

print('2)')

p = None

for _ in range(3):

   num = int(input('Введите число: '))

   if num % 10 != 0:

       if num % (num % 10) == 0:

           if p == None:

               p = num

           else:

               p *= num

if p != None:

   print(p)

else:

   print('Таких чисел нет!')

# 3

print()

print('3)')

numbers = []

for _ in range(3):

   num = float(input('Введите число: '))

   numbers.append(num)

if numbers[0] != numbers[1] and numbers[0] != numbers[2] and numbers[1] != numbers[2]:

   numbers = sorted(numbers)

   print(numbers[0], numbers[1], numbers[2])

else:

   print('Есть одинаковые числа')

# 4

print()

print('4)')

num = int(input('Введите число: '))

s = ''

if num in range(-999, 1000):

   if num == 0:

       s += 'нуль'

   else:

       if num < 0:

           s += 'отрицательное '

       else:

           s += 'положительнное '

       if num % 2 == 0:

           s += 'четное '

       else:

           s += 'нечетное '

       count = len(str(num).replace('-', ''))

       if count == 3:

           s += 'трёхзначное'

       if count == 2:

           s += 'двухзнатное'

       if count == 1:

           s += 'двухзнатное'

print(s)

       

# 5

print()

print('5)')

g = int(input('g: '))

m = int(input('m: '))

d = int(input('d: '))

if m in [1, 3, 5, 7, 8, 10, 12]:

   days = 31

if m == 2:

   days = 29

if m in [4, 6, 9, 11]:

   days = 30

d += 1

if d > days:

   m += 1

   if m > 12:

       g += 1

       m = 1

   d = 1

print(d, m, g)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота