masynchic
01.12.2021 20:01

Напишите программу для решения следующей : с клавиатуры вводятся 25 пар чисел. вывести на экран только те пары, сумма которых больше 100

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
aadiiii1
08.06.2020 19:21

Python 3:

l = [] # создание списка для хранения пар чисел

for i in range(25): # начало цикла

   n, m = map(int,input().split()) # ввод чисел

   if n + m > 100: # проверка условий

       l.append([n, m]) # добавление пары в список

for i in l:

   print(*i) # вывод пар

0,0(0 оценок)
Ответ:
котик963
08.06.2020 19:21
const    N = 25;var    arr: array[1..N, 1..2] of real;    firstNumber, secondNumber: real;    i, j: integer;begin    for i := 1 to N do        begin            Readln(firstNumber, secondNumber);                        Writeln();                        if (firstNumber + secondNumber > 100) then                begin                    j := j + 1;                                        arr[j, 1] := firstNumber;                    arr[j, 2] := secondNumber;                end;        end;        Writeln();        for i := 1 to j do        Writeln(arr[i, 1], ' | ', arr[i, 2]);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота