Mucuo31
28.04.2022 15:17

Написать программу: Даны две окружности, заданные в первой четверти системы координат. Задается координата и радиус каждой окружности. Необходимо выдать на экран: касаются ли окружности между собой?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alecsandrkozevn
31.03.2023 07:18

ответ:

векторное изображение - это тип изображения, которое состоит из объектов, описанных . свойства этой фигуры не будут изменяться при увеличении, поскольку фигура состоит из кривых. каждая точка этой фигуры имеет свои координаты, на этом фигура и основана, то есть заданы координаты точек, а между ними могут быть расположены различные кривые. их "искривленность" зависит от свойств точек. кривые могут иметь только цвет и толщину.

плюсы векторных изображений:

- гибкая масштабируемость, можно изменять размеры изображений без потери его визуальных качеств;

- максимальная точность построенного изображения (координаты точек, между которыми могут быть проведены кривые, могут иметь точность до сотых доль микрона) ;

- файл с векторным изображением имеет гораздо меньший размер по сравнению с растровым изображением;

- рисунок имеет высокое качество при печати, особенно это хорошо заметно на хороших принтерах при качественной печати;

- возможность редактирования всех частей векторного изображения;

- простой экспорт векторного рисунка в растровый.

минусы векторных изображений:

- отсутствие реалистичности у векторных рисунков. реалистичность достигается путем применения различных сложных цветовых схем;

- невозможность использования эффектов, которые можно применять в растровой графике;

- практически полная невозможность экспорта растрового рисунка в векторный;

растровое изображение - это изображение, в основе которого стоит таблица. ячейки таблицы - это пикселы. пиксел - это еденица измерения размеров растрового изображения. один пиксел - это одна клеточка в растровом изображении. соответственно растровые изображения состоят из пикселов, только они настолько малы, что в нормальном виде их трудно разлечить. каждый пиксел растрового изображения имеет следующие свойства: цвет и координаты расположения пиксела.

плюсы растрового изображения:

- высокая реалистичность изображения;

- на растровом изображении может быть изображено все, что угодно: как снимок с фотокамеры, так и нарисованное на компьютере изображение;

- к растровым изображениям можно применять самые разнообразные эффекты;

- растровые форматы рисунков используются при создании вэб-страниц в интернете;

недостатки растровых изображений:

- растровые изображения плохо масштабируются, можно уменьшить изображение, однако увеличить его без потери качества невозможно (к потери качества относиться заметное увеличение размытия изображения после увеличения рисунка) ;

- нельзя разбить растровое изображение на части и редактировать их;

- файл с растровым изображением имеет больший размер по сравнению с векторным.

0,0(0 оценок)
Ответ:
не0тличник
31.01.2023 13:48

#include <iostream>

#include <vector>

#include <cmath>

#include <set>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   set<pair<int,int>> s;

   int n;

   cin >> n;

   vector<int> a(n);

   for(int &i:a)

       cin >> i;

   int m;

   cin >> m;

   while(m--){

       int x,y;

       cin >> x >> y;

       s.insert({x,y});

       s.insert({y,x});

   }

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a[j] > a[j+1] && s.find({a[j],a[j+1]}) == s.end())

               swap(a[j],a[j+1]);

   for(int &i:a)

       cout << i << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота