AnnYtAa1
09.05.2022 08:27

Написать программу условия приема детей, в секцию баскетбола возраст которых не менее 9 лет и рост более 150 см.
Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
//Pascal ABC.NET 3.1 сборка 1219

Var
 k,n,max:integer;

 procedure hase(var k,n,max:integer); //сама последовательность
 begin
  if not(odd(n)) then n:=n div 2 else n:=n*3+1; //условие про чётность
  writeln(n); //вывод нового члена последовательности
  inc(k); //увеличение значения счётчика шагов
  if max<n then max:=n; //поиск вершины
 end;

  procedure start(var k,n,max:integer); //название процедуры намекает
 begin
  readln(n);
  k:=0;
  writeln('Seq:');
  max:=integer.MinValue;
  while n<>1 do
  hase(k,n,max);
  writeln('Шаги:',k);
  writeln('Вершина:',max);
 end;
 begin
 start(k,n,max);
end.
Пример ввода:
6
Пример вывода:
Seq:
3
10
5
16
8
4
2
1
Шаги:8
Вершина:16
0,0(0 оценок)
Ответ:
Маринрчка
03.08.2021 09:13

Вопрос 1 Дайте определение понятию "файл".

Варианты ответов

Файл - это текстовый документ.  @

Файл - это значок на рабочем столе.

Файл - это информация, которая хранится в памяти компьютера как единое целое и имеет свое название - имя файла.

Вопрос 2 Из скольких частей состоит имя файла?

Варианты ответов

Имя файла состоит из двух частей: название и расширение, которые отделяются друг от друга звездочкой.  @

Имя файла состоит из двух частей: название и расширение, которые отделяются друг от друга точкой.

Имя файла состоит из трех частей: название, знак вопроса, расширение.

Имя файла состоит из одной части - расширения.     возможно это@

Вопрос 3 Укажите верные утверждения.

Варианты ответов

В имени файла могут использоваться русские и латинские прописные и строчные буквы, а так же пробелы.  @

Длина имени файла (количество символов) не должна превышать 250.

В ОС Windows в имени нельзя использовать следующие символы: «\», «/», «:», «*», «?», «”», «<», «>», «|».

В ОС Linux в имени файла допустимы все символы, кроме «/».

Вопрос 4 Выберите, какие из вариантов ответов могут использоваться в качестве имен файлов в ОС Windows.

Варианты ответов

Music.

5>6.

Текст. @

2+3.

Ура-Ура.

Вопрос 5 Соотнесите типы файлов с их расширениями.

Варианты ответов

1.    Расширения графических файлов    а.    .wav, .mp3, .mid.

2.    Расширения текстовых файлов    б.    .bmp, .jpg, .gif.

3.    Расширения звуковых файлов        в.    .doc, .docs, .rtf. @

4.  Расширения исполняемых файлов    с. exe, com, bat

Вопрос 6 Укажите верные утверждения.

Варианты ответов

Для удобства хранения и быстрого поиска файлы группируются в папки (каталоги). @

Внутри папки не могут содержаться другие папки (каталоги). @

Во время работы на компьютере файлы и папки можно модифицировать, копировать, перемещать, удалять.

В одной папке могут содержаться 2 файла с одинаковым именем и расширением.

Вопрос 7 Какие из предложенных действий можно выполнять при работе на компьютере с файлами  и папками?

Варианты ответов

Открытие. @

Копирование.

Перемещение.

Удаление.

Вопрос 8 Выберите, какие из правил необходимо запомнить при работе с файлами.

Варианты ответов

Нельзя удалять файл без веских на то причин.

Нужно присваивать имя файлу такое, чтобы при последующей работе можно было узнать, что в нем находится, не открывая его. @

При необходимости можно удалять и не перемещать файлы прикладных программ.

Необходимо сохранять файл в той папке, в которой в последующем его можно будет легко отыскать. @

Вопрос 9 Сколько места в памяти компьютера будет занимать слово "Информатика"?

Варианты ответов

11 бит.

8 бит. @

11 байт.

1 Кбайт.

Вопрос 10 Укажите верные выражения.

Варианты ответов

1 бит=8 байт @

1 Кбайт=1024 байта

1 Гбайт=1024 Мбайт

1 Мбайт=1024 байт​

Объяснение:

варианты ответов подчеркнуты* @ * символом,я не уверена что все правильно

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота