helphelhelphelplease
19.05.2022 14:50

Написать программу, которая принимает на вход данные (фио, телефон, возраст) #иванов иван иванович,89091002020,30 ввод данных осуществляется до написания слова "стоп". программа должна посчитать количество человек, чьё имя "алексей" или префикс номер равен "904". 1 оценка: реализация ввода данных 2 оценка: алгоритм подсчёта человек для реализации 1 этапа: ввод осуществляется в цикле строка с данными разбивается в разные переменные проверять строку с данными на "стоп"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
мпрлкт
21.04.2022 10:19
Program z1; 
Var i,n,a,b,c:integer;     
 m: array [1..1000] of integer;
Begin 
write('Введите кол-во чисел - '); 
readln(n);   
randomize;   
a:=0;   b:=0;   c:=0; 
 for i:=1 to n do 
begin   
m[i]:=random(100)-50;   
 write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Ответ:
Ahamad
21.04.2022 10:19
Program z1;  Var i,n,a,b,c:integer;      m: array [1..1000] of integer;Begin  write('Введите кол-во чисел - ');  readln(n);   randomize;   a:=0;   b:=0;   c:=0;  for i:=1 to n do  begin    m[i]:=random(100)-50;    write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота