missgur04
09.04.2020 20:19

Расставьте строки кода в нужном порядке, чтобы получилась программа, выводящая на экран номера максимальных элементов в массиве
Расположите элементы в правильном порядке:
1
var i, N, max_el, max_num: integer;

2
begin

3
read(N);

4
max_el:=mas[1]; max_num:=1;

5
mas: array[1..10000] of integer;

6
for i:=1 to N do if mas[i]=max then write(i, ' ');

7
for i:=1 to N do read(mas[i]);

8
for i:=1 to N do if mas[i]>max_el then max_el:=mas[i];

9
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
agargo228
24.10.2020 10:28
1. Работаем с квадратной матрицей, где количество строк=количеству столбцов = 100
2. После выполнения фрагмента кода получим матрицу, в которой главная диагональ равна -1, -2, -3 ... -98, -99, -100 и все элементы над главной диагональю будут отрицательные, каждый следующий элемент в строке от главной диагонали будет меньше предыдущего на 1 и строка заканчиваются -100
3. Элементы под главной диагональю положительные  и равны номеру строки.
Пример такой матрицы (только не 100Х100, а 5Х5, просто не влезет в экран, но чтобы понять как формируется такой массив достаточно):
  -1  -2  -3  -4  -5
   2  -2  -3  -4  -5
   3   3  -3  -4  -5
   4   4   4  -4  -5
   5   5   5   5  -5

4. Далее можно вручную посчитать сумму элементов матрицы, а можно написать программу для этого:
const n = 100;
var a:array[1..n,1..n] of integer;
i,k,s:integer;
begin
  for i:=1 to n do begin
    for k:=1 to n do begin
      if i > k then
         A[i,k] := i
      else A[i,k] := -k;
      s:=s+a[i,k];
    end;
  end;
  writeln(s);
end.

ответ: -5050
0,0(0 оценок)
Ответ:
vladd010703
22.09.2022 02:14
Import java.util.Random;
import java.util.Scanner;

public class Main {

        public static void First() {
                Random random = new Random(System.currentTimeMillis());
                int[] numbers = new int[5];

                for (int i = 0; i < numbers.length; i++)
                        numbers[i] = random.nextInt(136) + 15;
       
                for (int num : numbers)
                        System.out.print(num + " ");
                System.out.println();
         
                double sum = 0;
         
                for (int num : numbers)
                        sum += num;
         
                System.out.println("Среднее арифметическое: " + sum / numbers.length);
        }
     
        public static void Second() {
                Random random = new Random(System.currentTimeMillis());
                int[] numbers = new int[20];
         
                for (int i = 0; i < numbers.length; i++)
                        numbers[i] = random.nextInt(45) + 1;
         
                Scanner scanner = new Scanner(System.in);
                int guessed = 0;
         
                for (int i = 0; i < 3; i++) {
                        System.out.print("Введите число: "); 
                        int num = scanner.nextInt();
             
                        for (int number : numbers)
                                if (number == num) {
                                        guessed++;
                                        break;
                                 }
                        if (guessed >= 2)
                                System.out.println("Ты выиграл!");
                        else
                                System.out.println("Ты проиграл...");
        }
     
        public static void main(String[] args) {
           
        }

}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота