Levi1234
20.11.2022 13:52

Составить программы для задач в Python
1.Напишите программу которая вводит номер месяца и выводит название времени года. При вводе неверного номера месяца, программа должна вывести сообщение "Такого месяца не существует".
2.Напишите программу, которая моделирует работу следующего автомата
Автомат получает на вход трехзначное целое число и строит новое число следующим образом:
1) Вычисляются суммы первой и второй, затем второй и третьей цифр;
2) Эти суммы записываются в порядке возрастания.
Например, для числа 639 получаем суммы: 6+3=9 и 3+9=12. Результат: 912

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
perrezz
09.06.2022 13:10

Объяснение:

Пошаговое объяснение:

Кажется, догадался.

1) Плывут взрослая горилла и взрослая шимпанзе. Горилла остаётся на том берегу. Шимпанзе возвращается.

2) Шимпанзе берет ребенка гориллы и перевозит. Оставляет ребенка на том берегу и возвращается.

3) Шимпанзе берет своего ребенка и перевозит. А в обратную дорогу берет ребенка гориллы и возвращает на этот берег.

В результате на 1 берегу оказывается ребенок шимпанзе, взрослая шимпанзе и два ребенка гориллы.

А на 2 берегу взрослая горилла и ребенок шимпанзе.

Всех поровну, никто никого не съел.

4) Шимпанзе забирает своего второго ребенка и перевозит на тот берег. Обратно возвращается горилла.

5 и 6) Горилла за два рейса перевозит обоих своих детей.

0,0(0 оценок)
Ответ:
аноним0000001
29.03.2023 14:48

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота