karakatitsa1
25.08.2021 10:39

Задача по информатике на массивы на языке Паскаль

Известны данные о годовой заработной плате сотрудников предприятия за 2019 год. Определить, кто из работников имел ЗП выше среднего. Какова разница между самой высокой и самой низкой ЗП.
Входные данные: N - количество сотрудников предприятия. Z - массив сведений о ЗП (ЗП – случайное число в интервале [100 000, 1 000 000]).
Вывод: 1) средний уровень ЗП;
2) номера сотрудников с ЗП выше среднего (в строчку, через запятую);
3) разница между уровнем самой высокой и самой низкой ЗП.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
menshikovborisg
10.02.2023 16:40

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

var current, past, sum: real;

    i, n: integer;

begin

  current : = 10;

  for i : = 1 to 10 do begin

    writeln(i, ' ', current);

    past : = current;

    current : = current * 1.1;

  end;

  current : = 10; sum : = 0;

  write('n = ');

  read(n);

  for i : = 1 to n do begin

    sum : = sum + current;

    past : = current;

    current : = current * 1.1;

  end;

  writeln('за ', n, ' дней: ', sum);

end.

0,0(0 оценок)
Ответ:
vladyulin
09.09.2021 14:42

1)Что такое поле БД?  (ответ) Поле базы данных - это столбец таблицы, содержащий значения определенного свойства. Строки таблицы являются записями об объекте; эти записи разбиты на поля столбцами таблицы, поэтому каждая запись представляет собой набор значений, содержащихся в полях.

2) Для чего нужно связывать таблицы в БД?

(ответ) Многие СУБД при связывании таблиц автоматически выполняют контроль целостности вводимых в базу данных в соответствии с установленными связями. В конечном итоге это повышает достоверность хранимой в БД информации.

3)  Что такое База данных? (ответ) представленная в объективной форме совокупность самостоятельных материалов, систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с электронной вычислительной машины

4)В каком режиме могут создаваться поля БД?

(ответ)

*создание таблицы в режиме конструктора;

*создание таблицы с мастера;

*создание таблицы путем ввода данных

5)  Если между таблицами БД установлены связи, то к чему может привести  изменение или удаление существующих полей? (ответ) Каждая запись в таблице "Сведения о заказах" содержит значение поля "КодТовара", которому соответствует запись в таблице "Товары" с тем же значением в данном поле. тут не уверен честно

6) Что такое ключевое поле БД?  (ответ)Ключевое поле — это одно или несколько полей, комбинация значений которых однозначно определяет каждую запись в таблице. Если для таблицы определены ключевые поля, то Microsoft Access предотвращает дублирование или ввод пустых значений в ключевое поле.

7) Назовите два основных этапа создания БД (ответ) Определить структуру базы данных и типа каждого поля. 2. Ввод данных. ... Поиск информации в базе данных на основе критериев поиска

8)При чего можно создать формы ввода данных в таблицу

(ответ)

инструмента Form;

инструмента Разделенная form;

инструмента Несколько элементов;

инструмента Пустая form;

Мастера form;

Конструктора form.

9)Приведите примеры типов полей (из разобранного видеоматериала)

(ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

10)Приведите примеры типов полей из разобранного видеоматериала (ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

11)Опишите тип поля счетчик своими словами (ответ) новое поле предназначенное для хранения часто изменяющихся целочисленных данных

12)Из каких файлов можно импортировать данные в таблицу БД? (ответ) импортировать таблицы, за формы, отчеты, макросы и модули из одной базы данных Access в другую. При импорте Access создает копию объекта в текущей базе данных.

(вроде всё!)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота