1. Выберите номер фрагмента программы, выполняющего такие же действия, что
и приведенный ниже:
for i:= 2 to 6 do begin x:=x+2*i;
x:=x+1;
end;
1) i:=2; while i< 6 do begin x:=x+2*i;
x:=x+1;
i:=i+1;
end;
2) i:=2; while i<= 6 do begin x:=x+2*i;
x:=x+1;
end;
3) i:=2; while i<=6 do begin x:=x+2*i;
x:=x+1;
i:=i+1;
end;
2.Определите значение переменной X после выполнения следующего фрагмента
программы:
x:=1;
repeat
x:=x+2;
x:=x+1;
until x>10;
3.Выберите аналогичный фрагмент приведенному выше, но записанный с цикла while.
1. X:=1;
While x>10 do begin x:=x+2; x:=x+1; end;
2. X:=1;
While x<10 do begin x:=x+2; x:=x+1; end;
3. X:=1;
While x<=10 do begin x:=x+2; x:=x+1; end;

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
круасана
02.10.2021 22:06
1) F=Av(¬A&B)
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB

2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B

3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B

4) F =(1v(AvB))v((AC)&1) 
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1
0,0(0 оценок)
Ответ:
Rezars19
10.08.2021 22:39
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота