маринка150
02.05.2020 04:16

Составить программу:

а) Вычисления сумму кубов натуральных чисел до тех пор, пока сумма кубов очередного числа не превысит 1000.

б) Вычисления значение функции Y=X2, при х= 8; 6; 4; 2.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yanaqwe
26.06.2020 13:36
Для сло­же­ния спра­вед­лив пе­ре­ме­сти­тель­ный (ком­му­та­тив­ный) закон, зна­чит, по­ря­док ко­манд в про­грам­ме не имеет зна­че­ния для ре­зуль­та­та.
Все ко­ман­ды уве­ли­чи­ва­ют ис­ход­ное число, по­это­му ко­ли­че­ство ко­манд не может пре­вос­хо­дить (35 − 20)/2 = 7.
При этом ми­ни­маль­ное ко­ли­че­ство ко­манд — 3.Таким об­ра­зом, ко­манд может быть 3, 4, 5, 6 или 7. По­это­му по­ря­док ко­манд не имеет зна­че­ния, каж­до­му числу ко­манд со­от­вет­ству­ет один набор ко­манд, ко­то­рые можно рас­по­ло­жить в любом по­ряд­ке.
Рас­смот­рим все воз­мож­ные на­бо­ры и вы­чис­лим ко­ли­че­ство ва­ри­ан­тов рас­спо­ло­же­ния ко­манд в них.
Набор 1111112 имеет 7 воз­мож­ных ва­ри­антов.
Набор 111113 - 6 вариантов
Набор 111222 - 20 воз­мож­ных ва­ри­ан­тов рас­по­ло­же­ния: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 6!/(3!·3!).
Набор 22222 - 1 вариант
Набор 11322 -  30 воз­мож­ных ва­ри­ан­тов рас­по­ло­же­ния: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 5!/(2! * 1! * 2!).
Набор 3312 - 12 ва­ри­ан­тов: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 4!/(2!·1!·1!))
Набор 333 - 1 вариант.

Всего имеем: 7 + 6 + 20 + 1 + 30 + 12 + 1 = 77 про­грамм. ответ: 77.

Теперь все точно! )
0,0(0 оценок)
Ответ:
aliceoliver443
11.05.2020 10:32
Using System;

namespace Znanija {
    internal class Program {

        private static void Main() {
            var r = new Random(DateTime.Now.Millisecond);
            var course = r.Next(1, 6);
            var students = new int[5,8];

            for (var i = 0; i < students.GetLength(0); i++) {
                for (var j = 0; j < students.GetLength(1); j++) {
                    students[i, j] = r.Next(10, 40);
                    Console.Write("{0:d2} ", students[i, j]);
                }
                Console.WriteLine();
            }

            Console.WriteLine("На курсе {0} кол-во студентов = {1}", course, CountStudents(students, course));
            Console.ReadKey();
        }

        private static int CountStudents(int[,] students, int course) {
            if (students.GetLength(0) < course) {
                Console.ForegroundColor = ConsoleColor.Red;
                Console.WriteLine("Нет курса " + course);
                return 0;
            }

            var number = 0;
            for (var i = 0; i < students.GetLength(0); i++) {
                number += students[course - 1, i];
            }

            return number;
        }

    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота