влад2305
14.10.2022 01:31

написать программу для создания изображения (использовать команду сместиться на вектор, циклический или вс алгоритм):

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Lehanbratkov
10.05.2021 12:07

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int GradesInformatics,  GradesPhysikc;

   cout << "Введите количество оценок по информатике" <<endl;

   cin >> GradesInformatics;

   cout << "Введите количество оценок по физике" << endl;

   cin>> GradesPhysikc;

   int* Informatics = new int[GradesInformatics];

   int* Physicks = new int[GradesPhysikc];

   int Tmp = 0;

    cout << "Введите оценки по информатике" <<endl;

   for (int i = 0; i < GradesInformatics; ++i) {

       cin >> Informatics[i];

   }

   cout << "Введите оценки по Физике" <<endl;

   for (int i = 0; i < GradesPhysikc; ++i) {

       cin >> Physicks[i];

   }

   for (int i = 0; i < GradesInformatics + GradesPhysikc; ++i) {

       Tmp = Tmp + Informatics[i] + Physicks[i];

   }

   if (Tmp > 8) {

       cout << "Молодец " << endl;

   }

   else {

       cout << "Постарайся " << endl;

   }

   delete[] Informatics;

   delete[] Physicks;

}

Объяснение:

Код на с++

Так как в задании не указано,сколько всего оценок может быть,то спрашиваем это в рантайме у пользователя. Затем получаем эти оценки при двух циклов for. Потом складываем всё,что получилось в tmp и выводим ответ

0,0(0 оценок)
Ответ:
lipa2907
07.02.2023 15:23
ответ:

Подключаем библиотеку...

uses graphABC;

Объявляем константы... x - сторона квадрата, c - кол. линий.

const  x = 200;   c = 10;

Объявляем начало работы программы:

begin  

Рисуем прямоугольник с противоположными вершинами (0;0) и (200;200):

 rectangle(0, 0, x, x);

Создаём цикл от 0 до с-1 (но по сути он пробегает с раз; с-1 для того чтобы потом -1 не лепить со скобками):

for var i := 0 to c - 1 do

Рисуем линию от точки (i * x div c; x - 1) до (x -1; i * x div c):

     line(i * x div c, x - 1, x - 1, i * x div c);

...("x - 1" из-за того, что pen.width = 1)

Объявляем конец работы программы:

end.
Составить программу для вывода в рабочее поле следующего графического изображения. Верхний левый уго
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота