lubovsher1
06.02.2022 23:37

Напишите программу, которая считывает одну строку. Если это строка «Python», программа выводит «ДА»; в противном случае программа выводит «НЕТ».

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Valeria13092004
17.09.2022 21:23
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int  li;#define mp          make_pair
#define F           first
#define S           second
#define sqr(a)      ( (a) * (a) )
#define pb          push_back
#define INF         999999999
#define ret(a)      cout << endl; system("pause"); return(a)
//#define ret(a)      return(a)using namespace std;int main()
{
    string s;
    cin >> s;
    cout << 1 << s << 1;
    ret(0);
}
0,0(0 оценок)
Ответ:
ddolgiev1
17.09.2022 21:23
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
   int n,k;
   cout<<"n = ";  cin>>n;
   int a[n],b[n];
   srand(time(NULL));
// запись в массив
   for (int i=0; i<n; i++) { 
       a[i]=15-rand()%30; cout<<a[i]<<" "; 
   }    
   cout<<endl;
//  сортировка массива по убыванию
   for (int i=0; i<n-1; i++)
   for (int j=i+1; j<n; j++)
       if (a[j]>a[i]) swap(a[i],a[j]);
// поиск первого отрицательного
   k=0;
   while (a[k]>=0) k++;
// запись положительных по убыванию
   for (int i=0; i<k; i++) b[i]=a[i];
//  запись отрицательных по возрастанию
   for (int i=k; i<n; i++) b[i]=a[n-i+k-1];
// вывод массива b
   for (int i=0; i<n; i++) cout<<b[i]<<" ";
   cout<<endl;
   system("pause");
   return 0;
}

n = 15
 -6 -9 -7 12 7 7 -6 6 11 -4 1 10 9 -8 -1 
12 11 10 9 7 7 6 1 -9 -8 -7 -6 -6 -4 -1 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота