Жибек20041
07.04.2020 20:31

ЛЕГКИЕ ЗАДАНИЯ В PASCAL

1. Написать программу для вывода на экран всех больших латинских букв в обратном порядке.
2. Дана маленькая русская буква. Написать программу, преобразовывающую ее в большую. ( СКРИН НИЖЕ, НЕ КОПИРУЙТЕ ОТВЕТ, ОН НЕ ПРАВИЛЬНЫЙ)
3. Даны строка S и символы А и В. Написать программу, заменяющую в строке S все символы, равные символу А, на символ В.
4. Даны строка S и символы А и В. Написать программу, заменяющую в строке S все символы, равные символу А, на символ В, а все символы, равные символу В, на символ А.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katenkafialkaowy2yf
04.05.2020 10:10

program z1;

const n=8;

var a:array [1..n] of integer;

i,m: integer;

begin

writeln ('Результаты заплыва: ');

for i:= 1 to n do

begin

write(i,'-й: ');

readln(a[i])

end;

writeln;

m:=a[i];

for i:= 1 to n do

if a[i]<m then m:=a[i];

writeln('Лучший: ',m)

end.

program z2;

const n=12;

var a:array [1..n] of integer;

i,m: integer;

begin

writeln ('Массив: ');

for i:= 1 to n do

begin

write(i,'-й элемент: ');

readln(a[i])

end;

writeln;

m:=a[i];

for i:= 1 to n do

if a[i]>m then m:=a[i];

writeln('Максимальный: ',m)

end.

Объяснение:

Сначала вводим элементы массива.

Затем предполагаем, что первый элемент наименьший (1 задача) или наибольший (2 задача). Потом сравниваем элементы массива с переменной, в которую записали первый элемент, и меняем переменную, если условие срабатывает. Выводим результат на экран.

0,0(0 оценок)
Ответ:
FinPinKin
07.06.2020 08:22
Program t;
varn, x, i, s, k:integer;
a:array [0..20] of integer; {20 =это максимальное количество домов .Вместо 20 поставь любое  число}
begin
write('Введите количество домов на улице : ');
read(n);
for i:=1 to n do
begin
write('Введите количество жителей в ', i, ' -м доме : ');
read(a[i]);
end; 
for i:=1 to n do    
if i mod 2=0 then s:=a[i]+s; {Считаем жителей правых}        
        for i:=1 to n do
        if i mod 2=1 then k:=a[i]+k;{Считаем жителей левых} 
if s>k then write('Разница между домами ', k-s ); 
if s<k then write('Разница между домами ', s-k );
end.

Введите количество домов на улице : 3
Введите количество жителей в 1 -м доме : 3
Введите количество жителей в 2 -м доме : 1
Введите количество жителей в 3 -м доме : 4
Разница между домами -6

Писал на Версии 3.3
Скобки это комментарии,их можно убрать
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота