vektar1234
16.03.2020 15:08

Написать программу вычисляющую произведение четных элементов на
промежутке [a,b]. Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dkogotyzeva
06.04.2021 21:24

var a,b,c,d,res: integer;

begin

write('Введите a: ');

readln(a);

write('Введите b: ');

readln(b);

write('Введите c: ');

readln(c);

write('Введите d: ');

readln(d);

res := a;

// Проверяем число b

if (b mod 10 > res mod 10) then res:=b

else if (b mod 10 = res mod 10) then

 begin

 if (res<b) then res:=b;

 end;

// Проверяем число c

if (c mod 10 > res mod 10) then res:=c

else if (c mod 10 = res mod 10) then

 begin

 if (res<c) then res:=c;

 end;

 

// Проверяем число d

if (d mod 10 > res mod 10) then res:=d

else if (d mod 10 = res mod 10) then

 begin

 if (res<d) then res:=d;

 end;

 

writeln('Число с наибольшей последней цифрой: ',res);

end.

0,0(0 оценок)
Ответ:
rozarafo5
06.04.2021 21:24

var a,b,c,d,res: integer;

begin

write('Введите a: ');

readln(a);

write('Введите b: ');

readln(b);

write('Введите c: ');

readln(c);

write('Введите d: ');

readln(d);

res := a;

// Проверяем число b

if (b mod 10 > res mod 10) then res:=b

else if (b mod 10 = res mod 10) then

 begin

 if (res<b) then res:=b;

 end;

// Проверяем число c

if (c mod 10 > res mod 10) then res:=c

else if (c mod 10 = res mod 10) then

 begin

 if (res<c) then res:=c;

 end;

 

// Проверяем число d

if (d mod 10 > res mod 10) then res:=d

else if (d mod 10 = res mod 10) then

 begin

 if (res<d) then res:=d;

 end;

 

writeln('Число с наибольшей последней цифрой: ',res);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота