lolola20051
07.04.2023 20:26

Укажите наименьшее натуральное число, при вводе которого эта программа напечатает
сначала 2, потом – 24.
var x, a, b: longint;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
if x mod 2 > 0 then
a := a + x mod 8
else
b := b * (x mod 8);
x := x div 8;
end;
writeln(a); write(b);
end

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
викуха308
18.06.2021 17:37
<<

   for (int i = 0; i < fabs(N); i++) {


       // выводим символ в консоль

       cout << sym;


   }


   // отступаем строчку и говорим, что программа закончилась

   cout << endl << "Finish draw" << endl;


}


void printColumn(int N) {


   // конвертируем число N в строку

   std::string s = std::to_string(N);


   // делаем цикл по всей строке. s.length вернет ее длинну.

   // любая строка это массив символов, а с массивами мы работаем циклами.

   for (int i = 0; i < s.length(); i++) {


       // выводим символ i в строке s

       cout << s[i] << endl;


   }


}


int main()

{

   cout << "Task 30241034!" << endl; // just for fun


   // вызываем первое. Передаю один аргумент т. к. второй уже стоит по умолчанию

   drawLine(-3);


   // вызываем второе

   printColumn(12);


   return 0;

}

0,0(0 оценок)
Ответ:
bugaamn1
02.01.2023 19:06
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018

begin

 var (a, b) := (ArrRandom, ArrRandom);

 Println('Исходные массивы: '); a.Println; b.Println; Println;

 var m := a.Zip(b, (x, y)-> max(x, y)).ToArray;

 

 Println('Конечные массивы: ');

 a := a.Select((t, i)-> t + m[i]).ToArray; a.Println;

 b := b.Select((t, i)-> t + m[i]).ToArray; b.Println;

 

 Println($'{NewLine}Сред. арифм. = {a.Average}');

 Println($'Минимальный = {b.Min}{NewLine}Максимальный = {b.Max}');

end.


Пример вывода в приложении.


Преобразовать два заданных массива, увеличивая их соответствующие элементы на большее из рассматрива
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота