normanajas15
18.02.2021 00:45

Написать программу в Pascal ABC с использованием массива: В классе 15 учеников писали работу по русскому языку.
Напишите программу, подсчитывающую количество двоек, троек, четвёрок и пятёрок, полученных за работу.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
загадка28
07.01.2023 07:35

1.

Зрительные представления;

Слуховые представления;

Двигательные представления;

Осязательные представления;

Обонятельные представления;

Вкусовые представления;

Температурные представления;

Органические представления.

2.

Действительные числа изображаются точками на числовой оси. Числовая ось – это прямая, на которой указаны: направление, начало отсчета и единица масштаба: Положительные числа откладываются справа, а отрицательные числа – слева от начала отсчета (точки О).

3.

Переменная типа (ти́повая переменная) в языках программирования и теории типов — переменная, которая может принимать значение из множества типов данных.

Ти́повая переменная используется в определении алгебраического типа данных подобно тому, как используется параметр в определении функции, но используется для передачи типа данных без передачи самих данных. В качестве идентификаторов ти́повых переменных в теории типов традиционно используются буквы греческого алфавита (хотя многие языки программирования используют латиницу и допускают и более длинные именования).

0,0(0 оценок)
Ответ:
Fidjit
22.11.2022 17:52
// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
procedure GetProdNeg(a:array of integer; var p:real);
// произведение отрицательных элементов
begin
  p:=a.Where(x->x<0).Aggregate(1.0,(p,e)->p*e)
end;

function IsPrime(n:integer):boolean:=
  Range(2,Round(sqrt(n))).All(i->n mod i<>0);

procedure ArrPrime(n:integer; var a:array of integer);
// массив простых чисел не больших n
begin
  a:=Range(2,n).Where(i->IsPrime(i)).ToArray
end;

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var r:real;
  GetProdNeg(a,r);
  Writeln('Произведение ',r);
  n:=ReadInteger('n=');
  var b:array of integer;
  ArrPrime(n,b);
  b.Println
end.

Тестовое решение:
n= 15
27 -7 -36 40 -15 -21 -47 -28 -12 45 3 -38 -15 1 -39
Произведение 27866837980800
n= 300
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота