hurremsultan30
17.05.2022 07:25

НАДО СЕГОДНЯ СДАТЬ!! Написать программу которая запрашивает массив из n целых чисел а затем определяет количество четных элементов и количество нечетных элементов и выводит их количество, а также сам исходный массив.

2. Написать программу которая запрашивает массив из н целых чисел, а затем складывает все положительные элементы и все отрицательные элементы и выводит их суммы, а также сам исходный массив.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
littlecat123
14.10.2020 13:10

def parity(array):

   count_chet = 0

   count_nechet = 0

   for i in array:

       if i % 2 == 0:

           count_chet += 1

       else:

           count_nechet += 1

   print('четные числа => ', count_chet)

   print('нечетные числа =>', count_nechet)

   print('кол-во чисел =>', count_nechet + count_chet)

   print(array)

   

parity([1, 2, 4, 5, 7, 8])

(в parity можешь подставить любой массив)

2-ое задание

def suma(numbers_array):

   print(sum(numbers_array))

   print(numbers_array)

suma([1, 2, -4, 5, 7, 8])

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота