lizavolod17
04.04.2022 03:12

Составьте программу на языку Паскаль для блок-схемы циклического алгоритма ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
матеки
15.01.2020 11:25
В СССР доступные бытовые магнитофоны распространились примерно со второй половины 1950-х — начала 1960-х годов. В это время возникло особое социальное явление — магнитофонная культура или «магнитиздат». Легкость копирования магнитных записей позволила почти неограниченно распространять произведения, не одобрявшиеся официальной идеологией, но популярные в народе: песни бардов и первых полуподпольных рок-групп, западную популярную музыку, неофициальные выступления писателей-сатириков, лекции по уфологии, передачи «вражеских голосов» и т. п.[30][31] Магнитофоны быстро вытеснили с рынка кустарную грамзапись — грампластинки, записанные на использованной рентгенопленке («музыка на ребрах»).
0,0(0 оценок)
Ответ:
Mashalove16
07.08.2021 01:58
Var s:string;
n,k,i:integer;
begin
for n:=1 to 2 do
 begin
 writeln('Введите строку ',n,':');
 readln(s);
 k:=0;
 for i:=1 to length(s) do
  begin
  case s[i] of
   '[': k:=k+1;
   ']': k:=k-1;
   end;
  end;
 if k=0 
 then writeln('В строке ',s,' количество [ и ] одинаково')
 else writeln('В строке ',s,' количество [ и ] не одинаково');
 end;
end.

Пример:
Введите строку 1:
c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c
В строке c:=a[imax,j]; a[imax,j]:=a[imin,j]; a[imin,j]:=c количество [ и ] одинаково
Введите строку 2:
Просто [ пример ]] со [[ скобками
В строке Просто [ пример ]] со [[ скобками количество [ и ] не одинаково
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота