Каке11
01.03.2023 23:14

1. Напишите программу в среде Кумир на алгоритмическом языке: Ввести три числа, найти их сумму, произведение и среднее арифметическое.
Пример:
Введите три числа:
4 5 7
На экране должно появиться:
4+5+7=16
4*5*7=140
(4+5+7)/3=5.333333
Соответственно, если ввести другие 3 числа, то результат на экране должен быть другим.

2. Напишите программу в среде Кумир на алгоритмическом языке: введите натуральное число. Вывести на экран его последнюю цифру

3. Напишите программу в среде Кумир на алгоритмическом языке: Дано трехзначное число. Вычислить сумму его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kristishkalniza
25.12.2023 17:13
Хорошо, вот решения задач на алгоритмическом языке в среде Кумир:

Задача 1: Найти сумму, произведение и среднее арифметическое трёх чисел.

```
-- Алгоритм:
-- Шаг 1: Ввести три числа
-- Шаг 2: Найти сумму трех чисел
-- Шаг 3: Найти произведение трех чисел
-- Шаг 4: Найти среднее арифметическое трех чисел
-- Шаг 5: Вывести результаты на экран

-- Программа:
program task1;
var
num1, num2, num3: integer;
sum, product: integer;
average: real;
begin
-- Шаг 1: Ввести три числа
read(num1, num2, num3);

-- Шаг 2: Найти сумму трех чисел
sum := num1 + num2 + num3;

-- Шаг 3: Найти произведение трех чисел
product := num1 * num2 * num3;

-- Шаг 4: Найти среднее арифметическое трех чисел
average := sum / 3;

-- Шаг 5: Вывести результаты на экран
writeln(num1, '+', num2, '+', num3, '=', sum);
writeln(num1, '*', num2, '*', num3, '=', product);
writeln('(', num1, '+', num2, '+', num3, ')/3=', average:0:6);
end.
```

Задача 2: Вывести последнюю цифру натурального числа.

```
-- Алгоритм:
-- Шаг 1: Ввести натуральное число
-- Шаг 2: Найти последнюю цифру числа
-- Шаг 3: Вывести последнюю цифру на экран

-- Программа:
program task2;
var
number, lastDigit: integer;
begin
-- Шаг 1: Ввести натуральное число
read(number);

-- Шаг 2: Найти последнюю цифру числа
lastDigit := number mod 10;

-- Шаг 3: Вывести последнюю цифру на экран
writeln('Последняя цифра числа:', lastDigit);
end.
```

Задача 3: Найти сумму цифр трехзначного числа.

```
-- Алгоритм:
-- Шаг 1: Ввести трехзначное число
-- Шаг 2: Найти первую цифру числа
-- Шаг 3: Найти вторую цифру числа
-- Шаг 4: Найти третью цифру числа
-- Шаг 5: Найти сумму цифр трехзначного числа
-- Шаг 6: Вывести сумму на экран

-- Программа:
program task3;
var
number, digit1, digit2, digit3, sum: integer;
begin
-- Шаг 1: Ввести трехзначное число
read(number);

-- Шаг 2: Найти первую цифру числа
digit1 := number div 100;

-- Шаг 3: Найти вторую цифру числа
digit2 := (number div 10) mod 10;

-- Шаг 4: Найти третью цифру числа
digit3 := number mod 10;

-- Шаг 5: Найти сумму цифр трехзначного числа
sum := digit1 + digit2 + digit3;

-- Шаг 6: Вывести сумму на экран
writeln('Сумма цифр числа:', sum);
end.
```

Надеюсь, эти решения помогут тебе понять, как написать программы на алгоритмическом языке Кумир. Если у тебя возникнут еще вопросы, не стесняйся обращаться!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота