Donisimys000000
06.11.2022 20:32

Составьте программу, которая будет находить суммы цифр числа (использовать div и mod). С оператора repeat…until.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Giga45
28.09.2022 13:28
1. 16 бит * 512 = 2 байт * 512 = 1024 байт = 1 Кбайт (4)
2. 480 бит / (2 байта) = 480 бит / 16 бит = 30 (4)
3. 2 Кбайта / 2048 = 2048 байт / 2048 = 1 байт = 8 бит (3)
4. 29 символов * 1 байт/символ = 29 байт = 232 бит (3)
5. 16 * 35 * 64 * 8 бит = 16 * 35 * 64 байт = 35 * 1024 байт = 35 Кбайт (1)
6. 6 Кбайт / (64 * 16 * 2 байт) = 6 Кбайт / (2 * 1024 байт) = 6 Кбайт / 2 Кбайт = 3 (2)
7. 18 Кбайт / (12 * 16 * 2 байт) = 18 * 1024 / (12 * 16 * 2) = 48 (3)
8. 25 Кбайт / (8 * 25 * 8 бит) = 25 * 1024 / (25 * 8) = 128 (1)
9. 256 * 16 бит = 256 * 2 байт = 512 байт (4)
10. 160 бит / 1 байт = 160 / 8 = 20 (3)
11. (1,5 Кбайт) / 3072 = (1,5 * 1024 байт) / (3 * 1024) = 0,5 байт = 4 бит (2)
12. 39 символов * 16 бит/символ = 39 * 16 бит = 39 * 2 байт = 78 байт (2)
13. 8 * 40 * 64 * 16 бит = 40 * 64 * 16 байт = 40 * 1024 байт = 40 Кбайт (1)
14. 80 Кбайт / (128 * 64 * 2 байт) = 80 Кбайт / (128 * 8 * 16 байт) = 80 Кбайт / (16 * 1024 байт) = 80 / 16 = 5 (3)
15. 30 Кбайт / (15 * 32 * 1 байт) = 30 * 1024 / (15 * 32) = 2 * 32 = 64 (4)
16. 75 Кбайт / (16 * 50 * 8 бит) = 75 Кбайт / (16 * 50 байт) = 75 * 1024 / (16 * 50) = 75 * 1024 / (25 * 32) = 3 * 32 = 96 (2)
17. 4 = 2^2, на 1 символ 2 бита. 2 бита * 40 = 80 бит = 10 байт (1)
18. 12 байт / 48 символов = (12 * 8 бит) / (12 * 4) = 2 бита, поэтому 2^2 = 4 (4)
19. 32 = 2^5, поэтому 5 бит на 1 символ. 25 байт / 5 бит = 25 * 8 / 5 = 40 (1)
20. 128 = 2^7, 7 бит на символ. 7 бит * 32 = 7 * 4 байт = 28 байт (3)
21. (9 байт) / 24 = 72 бит / 24 = 3 бит; 2^3 = 8 (2)
22. 8 = 2^3, 3 бита на символ. 45 байт / 3 бит = 15 байт / бит = 15 * 8 = 120 (3)
0,0(0 оценок)
Ответ:
allihen
14.02.2020 07:36

ответ: См. снимок экрана (код в объяснении)

Объяснение:

from getpass import getpass

from random import randint

def task1():

   while True:

       log = input('Login: ')

       if len(log) >= 5 and len(log) <= 10:

           break

   while True:

       pswrd = getpass('Password: ')

       if len(pswrd) >= 8:

           print('Logged in succesfully!')

           break

def task2():

   for i in range(5):

       a = int(input("Enter the start: "))

       b = int(input("Enter the end: "))

       print(randint(a, b))

def task4():

   s = input("Enter the string: ")

   if len(s) < 8:

       quit()

   print('1.', s[-3:-1])

   print('2.', s[4])

   print('3.', s[:8])

   print('4.', s[:-3])

def task5():

   names = ['Liam', 'Noah', 'Oliver', 'William', 'Elijah',

            'James', 'Benjamin', 'Lucas', 'Mason', 'Ethan']

   numbers = []

   for i in range(15):

       numbers.append(randint(1, 100))

   for j in range(0, 10, 2):

       print(names[j])

   for k in range(15):

       if numbers[k] > 10:

           print(numbers[k])


, у меня экзамен. Язык программирования - Python. 1 Уровень Задача 1 – Пользователь должен ввести л
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота