ghjcvsdhcs
04.03.2023 01:34

Снежинка

Дано нечётное число n. Создайте двумерный массив из n×n элементов, заполнив его символами "." (каждый элемент массива является строкой из одного символа). Затем заполните символами "∗" среднюю строку массива, средний столбец массива, главную диагональ и побочную диагональ. Для этого не нужно использовать вложенные циклы.

В результате символы "звёздочка" в массиве должны образовывать изображение снежинки. Выведите полученный массив на экран, разделяя элементы массива пробелами.

Входные данные

В одной строчке задано число n≤21.

Выходные данные

ответ на задачу.

Примеры

Ввод
5
Вывод
* . * . *
. * * * .
* * * * *
. * * * .
* . * . *

код на языке python 3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
esenjel
14.10.2020 12:14

n = int(input())

a = [["."] * n for i in range(n)]

for i in range(n):

   # линия по диагонали

   a[i][i] = "*"

   # линия обратной диагонали

   a[n - 1 - i][i] = "*"

   # линия по вертикали

   a[i][n//2] = "*"

   # линия по горизонтали

   a[n//2][i] = "*"

print('\n'.join([' '.join([str(i) for i in row]) for row in a]))

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота