karina847
05.05.2022 22:41

Напишите программу сортировки подсчётом по возрастанию на Free Pascal. Входные данные берутся из текстового файла input.txt. Отсортированный массив записывается в output.txt.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Артемка0610
14.09.2020 08:17

Значение M поменяй в соотстветсвие диапазону.

const M = 100;

var n,i,d:longint;

   a:array[-M..M] of longint;

begin

 assign(input,'input.txt'); reset(input);

 assign(output,'output.txt'); rewrite(output);

 fillchar(a,sizeof(a),0);

 read(n);

   for i:=1 to n do

   begin

   read(d);

   inc(a[d]);

   end;

 

   for i:=-M to M do

   begin

     for d:=1 to a[i] do

     write(i,' ');

   end;

 close(input);

 close(output);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота