nikita140982ee
12.03.2023 09:58

Напишите программу, которая считывает натуральное число n и выводит на экран случайное натуральное число, меньшее n и оканчивающееся на 1. Гарантируется, что будет ввeдено натуральное число 1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
darinamel196
14.10.2020 12:06

Программа:

program MrSolution;

var n: integer;

function MrSolutionRandom(topBorder: integer):integer;

var rand: integer;

begin

 randomize;

 rand:= random(0, topBorder-1);

 MrSolutionRandom:= rand-rand mod 10+1;

end;

begin

  write('Введите натуральное число, кроме 1 >> ');

  repeat

    readln(n);

  until n<>1;

  writeln(MrSolutionRandom(n));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота