Rogonova
05.08.2021 15:44

Число элементов массива формировалось случайным образом из диапазона -50 9 вывод массива осуществляется в столбец

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lelyaklochkova
03.05.2021 14:57

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
0,0(0 оценок)
Ответ:
ekaterinatrushkova
28.01.2022 02:53

adminlogs=["0000","1488"] #Логин(ы) администратора

cars = [['priora - 300$', 300], ['mazda - 400$', 400],['ferari - 1300$', 1300],['BMW - 3000$', 3000]]

info="\n".join(("",

     "Справка:",

     "Сменить профиль: Выйти",

     "Посмотреть список авто: Просмотр",

     "Выбрать авто: Выбор {название}",

     "Купить авто: Купить",

     "Повторно вызвать справку: Справка",

     "*Администраторам*",

     "Добавить авто: Добавить {название цена}",

     "Удалить авто: Удалить",

     "Изменить название: Изменить {название}",

     ""))

def connect():

   global name,money_of_customer,login,permit

   print("*Попытка авторизации*")

   try:

       name=input("Введите Имя: ")

       money_of_customer=int(input("Введите баланс вашего счета: "))

       login=input("*Дополнительно* Введите логин администратора: ")

       permit=login in adminlogs

       print("Здравствуйте,",name)

   except:

       print("Ошибка авторизации, повторите")

       connect()

       return

def logout():

   connect()

def showcarlist():

   for i in cars:

       print(i[0])

def choosecar(car_name):

   global car

   for i in range(len(cars)):

       if car_name.lower() in cars[i][0].lower():

           print("Вы выбрали:",cars[i][0])

           car = i

           return

   print("Данного автомобиля нету в нашем каталоге")

def buycar():

   global money_of_customer, car

   if money_of_customer>=cars[car][1]:

       money_of_customer-=cars[car][1]

       print("Автомобиль", cars[car][0], "куплен")

       if permit:

           print("Уведомление: элемент", cars[car],"удален")

       cars.pop(car)

       del car

   else: print("Автомобиль не куплен")

def carmanage(flag,carinfo=None):

   global car

   if permit:

       if flag==0:

           res=carinfo.split(" ")

           cars.append([res[0] + " - " + res[1] + "$",int(res[1])])

           print("Уведомление: элемент", carinfo,"добавлен администратором")

       elif flag==1:

           print("Уведомление: элемент", cars[car][0],"удален администратором")

           cars.pop(car)

           del car

       elif flag==2:

           res=carinfo+" - "+str(cars[car][1])+"$"

           print("Уведомление: элемент", cars[car][0],"заменен администратором на", res)

           cars[car][0]=res

   else: print("У вас недостаточно прав")

connect()

print(info)

while True:

   print(name,money_of_customer,login,permit)

   do=input("Ваше действие... ").split(" ")

   doword=do[0].lower()

   try:

       if doword == "выйти":

           logout()

       elif doword == "просмотр":

           showcarlist()

       elif doword == "выбор":

           choosecar(do[1])

       elif doword == "купить":

           buycar()

       elif doword == "справка":

           print(info)

       elif doword == "добавить":

           carmanage(0, " ".join(do[1:]))

       elif doword == "удалить":

           carmanage(1)

       elif doword == "изменить":

           carmanage(2,do[1])

       else: print("Такой команды не существует")

   except:

       print("Произошла ошибка")

Объяснение:

Как то так) На дебаг времени не хватило, проверьте... Если проблемы есть - пишите

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота